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Introduction

This manual explains how to use CodeWarrior™ development tools to develop
applications for the Freescale' ColdFire® family of integrated microprocessors.

This chapter consists of these sections:

* Read the Developer Notes

* Features

¢ CodeWarrior Editions

¢ About this Manual
¢ Documentation Overview

¢ Additional Information Resources

Read the Developer Notes

Before using the CodeWarrior IDE, read the developer notes. These notes contain
important information about last-minute changes, bug fixes, incompatible elements, or
other topics that may not be included in this manual.

NOTE  The release notes for specific components of the CodeWarrior IDE are located
at location: {CodeWarrior_Dir}\Release_Notes, where
{CodeWarrior_Dir} isthe CodeWarrior installation directory.

If you are new to the CodeWarrior IDE, read this chapter and the Getting Started chapter.
This chapter provides references to resources of interest to new users; the Getting Started
chapter helps you become familiar with the software features.

Features

The CodeWarrior Development Studio for ColdFire Architectures includes these features:
» Latest version of the CodeWarrior IDE, which the IDE User’s Guide explains.
* Support for the latest ColdFire processors: MCF5222x and MCF5223x.

* Support for previous processors of the ColdFire family, such as MCF547x/548x,
MCF5206, MCF5208, MCF5213 (and its variants MCF5211 and MCF5212),

ColdFire Architectures v6.3 - Targeting Manual 7
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MCF523x, MCF5282, MCF5271, MCF5272, MCF5275, MCF5282, MCF5307,
MCF5329, and MCF5249. For more information, see ColdFire Processor

¢ Flash-programmer and hardware-diagnostics support. For more information, see
Using Hardware Tools.

* Remote connection debugging support for a range of protocols:

— Abitron protocols, see Abatron Remote Connections.

— Freescale’s USB TAP, see Freescale Remote Connections.

— P&E Micro protocols, see P&E Microsystems Remote Connections.
¢ Instruction Set Simulator (ISS) for V2 and V4e processor cores. For more
information, see Remote Connections for Debugging and Instruction Set Simulator

* Simple profiler support. For more information, see Using the Simple Profiler. (This
profiler support is not available for MCF521x, MCF5222x, and MCF5223x
processors.)

CodeWarrior Editions

There are three editions of CodeWarrior™ Development Studio for ColdFire®
Architectures, version 6.3. Table 1.1 shows their feature differences.

Table 1.1 CodeWarrior ColdFire 6.3 Edition Features

Feature Special Standard Professional Edition
Edition Edition

IDE Yes Yes Yes

Compiles source ASM and C ASM and C ASM, C, and C++

code

Code size 128KB None None

restrictions

Compiler Unlimited Unlimited Unlimited

optimization levels

3rd-party plug-ins No RTOS No RTOS Unlimited RTOS plug-ins

CodeWarrior Yes Yes Yes

Debugger

8 ColdFire Architectures v6.3 - Targeting Manual
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Table 1.1 CodeWarrior ColdFire 6.3 Edition Features (continued)

Feature Special Standard Professional Edition
Edition Edition

Debugger P&E Parallel P&E Parallel P&E Parallel, USB, and

hardware and USB, and USB, Lightning; Abatron serial

connections Cyclone Max, Cyclone Max, and TCP/IP, Cyclone
and USB TAP and USB TAP Max, and USB TAP

V2, V4e simulator No Yes Yes

Flash programmers | CodeWarrior CodeWarrior CodeWarrior Flash
Flash Flash Programmer and ColdFire
Programmer Programmer Flasher standalone plug-
(129 and ColdFire in
megabytes)and | Flasher
ColdFire standalone
Flasher plug-in
standalone
plug-in

Real time operating | Not available Not available Plug-ins available

system (RTOS)

Availability Free with Available Available through all
evaluation through all channels. 30-day
board channels evaluation copy also

available.
About this Manual
Table 1.2 lists the contents of this manual.
Table 1.2 Chapter, Appendix Contents
Chapter/Appendix Explains

New features; contents of this manual; technical
support; further documentation

Introduction

System requirements; overview of CodeWarrior
development tools

Getting Started

Application Tutorial Tutorial for writing and debugging programs

Target Settings Controlling the compiler and linker

ColdFire Architectures v6.3 - Targeting Manual 9
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Table 1.2 Chapter, Appendix Contents (continued)

Chapter/Appendix Explains

Debugging Debugger settings panels; remote debugging
connections

Instruction Set Simulator Instruction Set Simulator, including configuration for

your requirements.

Using Hardware Tools Flash programmer and hardware diagnostics tools
Using Debug Initialization Debug initialization files
Files

Memory Configuration Files Defining access for areas of memory

Documentation Overview

Documentation for your CodeWarrior tools comes in three formats:

¢ PDF manuals — in subdirectory \Help\ PDF of your installation directory.

NOTE  For complete information about a particular topic, you may need to look in this
Targeting manual and in the corresponding generic CodeWarrior manual.
To view any PDF document, you need Adobe® Acrobat® Reader software,
which you can download from: http: //www.adobe.com/acrobat

¢ CHM help files — information in Microsoft® HTML Help CHM format, in folder
\Help of the CodeWarrior installation directory. To view this information, start the
CodeWarrior IDE, then select Help > Online Manuals from the main menu bar.

¢ CodeWarrior online help — information about using the IDE and understanding
error messages. To access this information, start the CodeWarrior IDE, then select
Help > CodeWarrior Help from the main menu bar.

Additional Information Resources

¢ CodeWarrior IDE and related documentation can be found in the \Help\PDF
subdirectory of your CodeWarrior installation directory:

* For general information about the CodeWarrior IDE and debugger, see the IDE 5.7
User’s Guide.

* For information specific to building (compiling and linking), see the ColdFire Build
Tools Reference.

10 ColdFire Architectures v6.3 - Targeting Manual
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¢ For information about the Main Standard Libraries for C/C++, see the MSL C
Reference and the MSL C++ Reference.

¢ For PDF-format documentation about Freescale processors and cores, go to the
\Freescale_Documentation subdirectory of your CodeWarrior installation
directory.

¢ For Freescale documentation and resources, visit the Freescale, Inc. web site:
http://www. freescale.com

* For additional electronic-design and embedded-system resources, visit the EG3
Communications, Inc. web site: http://www.eg3.com

¢ For monthly and weekly forum information about programming embedded systems
(including source-code examples), visit the Embedded Systems Programming
magazine web site: http://www.embedded.com

ColdFire Architectures v6.3 - Targeting Manual 11
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Getting Started

This chapter helps you install the CodeWarrior™ Development Studio for ColdFire
Architectures. It also gives an overview of the CodeWarrior environment and tools.

This chapter consists of these sections:

¢ System Requirements

CodeWarrior IDE

CodeWarrior Development Process

System Requirements

Your host computer system and your target board must meet minimum requirements.

Host Requirements

Your computer (PC) needs:

800 MHz Pentium®—compatible microprocessor

Windows® 2000 or XP operating system

512 megabytes of RAM

CD-ROM drive

350 megabytes free memory space, plus space for projects and source code

Serial port (or Ethernet connector), to connect your PC to the embedded target — for
debugging with an Abatron BDI device or P&E Cyclone Max through Serial

Parallel port (or P&E Lightning board) — to use a P&E parallel cable to connect to
BDM/JTAG targets

USB port — To use a P&E USB BDM debug cable (Cyclone Max or P&E USB
Multilink) or Freescale USB TAP

Ethernet connector -- to connect your PC to the embedded target for debugging with
an Abatron BDI device or P&E Cyclone Max through TCP/IP

ColdFire Architectures v6.3 - Targeting Manual 13
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Target Board Requirements

Your functional embedded system needs:
¢ ColdFire evaluation board, with a supported processor.

¢ Serial or null-modem cables to connect the host computer and target board, in case
you would like to send printf output to a terminal; your target board determines the
specific cables you need.

* BDM connector to be able to connect a supported BDM cable.
* Appropriate power supply for the target board.

CodeWarrior IDE

The CodeWarrior IDE consists of a project manager, a graphical user interface, compilers,
linkers, a debugger, a source-code browser, and editing tools. You can edit, navigate,
examine, compile, link, and debug code, within the one CodeWarrior environment. The
CodeWarrior IDE lets you configure options for code generation, debugging, and
navigation of your project.

Unlike command-line development tools, the CodeWarrior IDE organizes all files related
to your project. You can see your project at a glance, so organization of your source code
files is easy. Navigation among those files is easy, too.

When you use the CodeWarrior IDE, there is no need for complicated build scripts or
makefiles. To add or delete source code files from a project, you use your mouse and
keyboard, instead of tediously editing a build script.

For any project, you can create and manage several configurations for use on different
computer platforms. The platform on which you run the CodeWarrior IDE is called the
host. From the host, you can use the CodeWarrior IDE to develop code to target various
platforms.

Note the two meanings of the term target:

¢ Platform Target — The operating system, processor, or microcontroller in which/
on which your code will execute.

¢ Build Target — The group of settings and files that determine what your code is, as
well as controlling the process of compiling and linking.

The CodeWarrior IDE lets you specify multiple build targets. For example, a project can
contain one build target for debugging and another build target optimized for a particular
operating system (platform target). These build targets can share project files, even though
each build target uses its own settings. After you debug the program, the only actions
necessary to generate a final version are selecting the project’s optimized build target and
using a single make command.

14

ColdFire Architectures v6.3 - Targeting Manual



Getting Started
CodeWarrior Development Process

The CodeWarrior IDE’s extensible architecture uses plug-in compilers and linkers to
target various operating systems and microprocessors. For example, the IDE internally
calls a C translator, compiler, and linker.

Most features of the CodeWarrior IDE apply to several hosts, languages, and build targets.
However, each build target has its own unique features. This manual explains the features
unique to the CodeWarrior IDE for Freescale ColdFire processors.

For comprehensive information about the CodeWarrior IDE, see the Code Warrior IDE
User’s Guide.

CodeWarrior Development Process

The CodeWarrior IDE helps you manage your development work more effectively than
you can with a traditional command-line environment. Figure 2.1 depicts application
development using the IDE.

ColdFire Architectures v6.3 - Targeting Manual 15
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Figure 2.1 CodeWarrior IDE Application Development

|Create/Manage ProjectfT— 7

| Manage Files (1) @)
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pecify Target
| Settings @) | Notes:

. (1) Use any combination: stationery

| ‘ Edit Files  (3) | (template) files, library files,
Lo o or your own source files.

; (2) Compiler, linker, debugger
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Build (Make) Project — —
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I

|
G
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-
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Release
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Project Files

A CodeWarrior project consists of source-code, library, and other files. The project
window (Figure 2.2) lists all files of a project, letting you:

* Add files

* Remove files

* Specify the link order

* Assign files to build targets

* Have the IDE generate debug information for files

Figure 2.2 Project Window

MyProjmep |
[© M5213EvBInemalROM ~| B & B g >
Files | Link Drderl Targetsl
¢ | Fie | Code [ Data [W0/w€ =]
@ 83 Source 0 0+ « ==
¢ @ mainc 0 D o
w {7 Linker Command Files I o« =l
@ [#-{] Runtime, FP, C, and UART lib 0 o« u
W &3 Support files I 0« « =
¢ [ readme.tst nda nia =l
[
17 files 0 0 |

NOTE  Figure 2.2 shows a floating project window. Alternatively, you can dock the
project window in the IDE main window or make the project window a child of
the main window. You can have multiple project windows open at the same
time; if the windows are docked, their tabs let you control which one is at the
front of the main window.

The CodeWarrior IDE automatically handles dependencies among project files, storing
compiler and linker settings for each build target. The IDE tracks which files have
changed since your last build, recompiling only those files during your next project build.

A CodeWarrior project is analogous to a collection of makefiles, as the same project can
contain multiple builds. Examples are a debug version and release version of code, both
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part of the same project. As earlier text explained, build targets are such different builds
within a single project.

Editing Code

The CodeWarrior text editor handles text files in MS-DOS, UNIX, and MacOS formats.

To edit a source code file (or any other editable project file), double-click its filename in
the project window. The IDE opens the file in the editor window (Figure 2.3). This
window lets you switch between related files, locate particular functions, mark locations
within a file, or go to a specific line of code.

Figure 2.3 Editor Window

-ioix
b} -m- - o' - Path: |E:\Program Files'MetrowerkshCw far ColdFire B.0MyPro).. \main.c <>
\ Durpsss:  sampie progras =

#include <stdic.h>

int main{)
*
printf {"Hello World MW in Chnbe");
fflush({=tdout) ;
while(l); ¢/ Idle
}
-
Ling 1 Coll | |4 vz

NOTE  Figure 2.3 shows a floating editor window. Alternatively, you can dock the
project window in the IDE main window or make the project window a child of
the main window.

Building: Compiling and Linking
For the CodeWarrior IDE, building includes both compiling and linking. To start building,
you select Project > Make, from the IDE main menu bar. The IDE compiler:

¢ Generates an object-code file from each source-code file of the build target,
incorporating appropriate optimizations.

18
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* Updates other files of the build target, as appropriate.
* In case of errors, issues appropriate messages and halts.
When compilation is done, building moves on to linking. The IDE linker:
* Links the object files into one executable file, in the link order you specify.
¢ In case of errors, issues appropriate error messages and halts.

When linking is done, you are ready to test and debug your application.

NOTE  Itis possible to compile a single source file. To do so, select the filename in the
project window, then select Project > Compile from the main menu bar.
Another useful option is compiling only the modified files of the build target:
select Project > Bring Up To Date from the main menu bar.

Debugging
To debug your application, select Project > Debug from the main menu bar. The
debugger window opens, displaying your program code.

Run the application from within the debugger to observe results. The debugger lets you set
breakpoints, to check register, parameter, and other values at specific points of code
execution.

NOTE  Todebug code stored in Flash memory, you first must program the Flash. (The
Flash Programmer subsection explains how to program a flash device.)

When your code executes correctly, you are ready to add features, to release the
application to testers, or to release the application to customers.

NOTE  Another debugging feature of the CodeWarrior IDE is viewing preprocessor
output. This helps you track down bugs caused by macro expansions or another
subtlety of the preprocessor. To use this feature, specify the output filename in
the project window, then select Project > Preprocess from the main menu bar.
A new window opens to show the preprocessed file.

Disassembling

To disassemble a compiled or ELF file of your project, select the file’s name in the project
window, then select Project > Disassemble. In order to add an ELF file to the project
view for disassembly, in Windows Explorer, point to the ELF file and drag it to the project
in the CodeWarrior IDE. Right click on the file name and select disassemble.
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After disassembling the file, the CodeWarrior IDE creates a . dump file that contains the
disassembled file’s object code in assembly format, and debugging information in
Debugging With Attribute Record Format (DWARF). The . dump file’s contents appear
in a new window.

20 ColdFire Architectures v6.3 - Targeting Manual



Application Tutorial

This chapter takes you through the CodeWarrior™ IDE programming environment. This
tutorial does not teach you programming. It instead teaches you how to use the
CodeWarrior IDE to write and debug applications for a target platform.

The examples in this chapter have been chosen for MCF5208-based code development. If
you are using a different ColdFire processor, you will need to substitute the appropriate
device name in the examples. Also, this tutorial assumes that debugging will be done
using CCS-SIM instead of real hardware. See Remote Debugging Panel for details on
connecting to a physical target evaluation board (EVB).

If you are using an EVB, then before you start this tutorial, you should configure the
hardware. Typically, this entails:

* Veritying all jumper-header and switch settings,
¢ Connecting the EVB to your computer, and

¢ Connecting EVB power.
NOTE  For complete setup instructions, see the EVB’s own documentation.

This chapter consists of these sections:

* Create a Project
¢ Build the Project
¢ Debug the Application

Create a Project

This section shows how to use stationery to create a new project for a ColdFire EVB, and
how to set up the project to make a standalone application. Follow these steps:

1. Select Programs > Freescale CodeWarrior > CodeWarrior for ColdFire V6.3 >
CodeWarrior IDE. The CodeWarrior IDE starts and the main window (Figure 3.1)
appears.

2. From the main menu bar, select File > New. A New dialog box (Figure 3.2) appears.
a. Select ColdFire Stationery.

b. In the Project name text box, type MyProj.
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NOTE  The default project location is the CodeWarrior installation directory. For
example, if the project name is abe and the installation directory is
CodeWarrior_Dir, the default location is CodeWarrior_Dir\abc.
For a different location, click the Set button, then use the subsequent dialog
box to specify the location. Clicking OK returns you to the New dialog box.

c. Click OK. The New Project dialog box (Figure 3.3) appears.

Figure 3.1 CodeWarrior IDE Main Window

{# Freescale Codewarrior M=l B3
| File Edt View Search Project Debug Took Window Help

bl =xhaA A meNsHERE

[ A

Figure 3.2 New Dialog Box

New B
Proiect | File | Object|
Froject name:
”@ Empty Project IMyProi
i) Evternal Build \wizard
Location:
IE:\my_proiects\MyF'roi Set...
Aidd ta Froject:
Project:

| i

oK I Cancel
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Figure 3.3 New Project Dialog Box

New Project E

Select project stationery:

Froject Stationery
A CF_t5206EC3
CF_MB208EVE
- CF_MB211DEMO
- CF_MB213EVE

- CF_MB2230DEMO
CF_MB2233DEMO
CF_MB2235EVE
CF_MB235EVE
CF_MB5249C3

- CF_MB2F1EVE

EEEEEE

hd
)8 I Cancel |

3. Specify CF_M5208EVB C stationery.

a. Click the CF_M5208EVB expand control — the tree structure displays the
subordinate option C.

b. Select C, as Figure 3.4 shows.

Figure 3.4 New Project Dialog Box: Selecting M5208 C Stationery

New Project E

Select project stationery:

IE Froject Stationery
- CF_MB206EC3 -
=~ CF_ME208EVE
? |
- CPP
‘. ECPP
- CF_MB211DEMO
- CF_MB213EVE
- CF_MB2230DEMO
- CF_MB2233DEMO
- CF_MB2235EVE

p———— hd
oK I Cancel |

EEEEE

NOTE  Many possible ColdFire target processors have an external bus, so can use

large external RAM devices for debugging applications during development.
But M5211, M5212, and M5213 processors do not have an external bus, so
must accommodate applications in on-chip memory. Although this on-chip
RAM accommodates CodeWarrior stationery, it probably is too small for full
development of your application. Accordingly, for these processors, you

should locate your applications in flash memory. (The Flash Programmer
subsection explains how to program a flash device.)
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c. Click OK. The CodeWarrior IDE creates a new project consisting of the folders
and files (header, initialization, common, and so forth) that the M5208 C stationery
specifies. The project window (Figure 3.5) appears.

Figure 3.5 Project Window

MyProj.mcp B

[ 9 M5208EVE Console Debun ~ | {1 &7 B g >
Files | Link Drderl Targetsl
¢ | Fie | Code [ Data [W0/w€ =]
¥ F{] Source ] 0 o =~
w {7 Linker Command Files I o« =l
@ [#-{] Runtime, FP, C, and UART lib 0 (1 u
[#{_3 Coldfire Suppart Files ] I =l
{3 UART Support files ] I =l
¢ [ readme.tst nda nia =l
[
18 files 0 0 A

4. Make sure that the target field (immediately under the project-window tab) specifies
M5208EVB Console Debug.

NOTE Files in the project data folder include information about the project file,
various target settings, and object code. Do not change the contents of this
folder, or the CodeWarrior IDE could lose project settings.

5. This completes project creation. You are ready to build the project, per the procedure
of the next section.

NOTE  While your source file (main. c) is open in the editor window, you can use all
editor features to work with your code.
If you wish, you can use a third-party editor to create and edit your code,
provided that this editor saves the file as plain text.
For information about the editor window, touching files, and file
synchronization, and removing/adding text files, see IDE User’s Guide.
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Build the Project

This section shows how to select the linker, set up remote debugging, and build (compile
and link) your project.

NOTE  The stationery for this project includes a default setup for the linker specific to
the application’s target platform.

Follow these steps:

1. Select the appropriate linker.

a. Select Edit > Target Settings (where Target is the name of the current build
target). The Target Settings window (Figure 3.6) appears.

NOTE In this tutorial, the name of the build target is M5208EVB Console Debug. So
the Target Settings window title is M5208EVB Console Debug Settings.

Figure 3.6 Target Settings Window: Target Settings Panel

i @M5208EYB Console Debug Settings [MyProj.mcp] HE

IE Target Settings Panels IE Target Seftings
= Target -

q Target Mame: |M52DSEVB Conzole Debug
- Access Paths . —
. Eild Extras Llnker:IEmbedded CaldFire Linker
- Runtime Settings Pre-linker:INone

- File M appings
- Source Trees
- Coldfire Target Output Directory:

- Language Seftings Chooze... |
|{Pr0iect}

- [C/C++ Language

- CAC++ Preprocessor ﬂl

o CAC++ Woani ] ] ] ] )
Eold:ifre .:s[:;:?l:ler [T Save project entries using relative paths

K KRN

Post-linker:lNone

= Code Generation

+ ColdFire Processor

‘o Global Optimizations

= Linker

+ ELF Disassembler |

Factory Settings Frewert Import Panel... | Export Panel... |

QK | Cancel | Apply |

b. From the Target Settings Panels list, select Target Settings.
The Target Settings panel moves to the front of the window.
Use the Linker list box to specify the Embedded ColdFire Linker.
d. Click Apply. The IDE saves the new linker setting for the build target.
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NOTE  This linker change applies only to the current build target. To use a different
build target, you must specify its appropriate linker.

For an actual target board, instead of the simulator, you would need to make
board connections by this point.

2. Set Up Remote Debugging.
a. From the Target Settings Panels list, select Remote Debugging.

The Remote Debugging settings panel moves to the front of the Target Settings
window, as Figure 3.7 shows.

Figure 3.7 Target Settings Window: Remote Debugging Panel

i EM5208EYB Console Debug Settings [MyProj.mcp] EHE
IE Target Settings Fanels ||E Fiemote Debugging
i Build Extraz ;I - -
Runtime Settings ' belimos
File: Mappings Eonnection:lw vl Edit Connection... |
Sourc.:e Trees Remate download path
Coldfire T arget I
+ ColdFire Processor
Global Dptimizations [ Launch remate host application
= Linker
> ELF Dizazzembler I
o ColdFire Lirker
= Editor
“ Custom Keywords
= Debugger
i Diebugger Settings [~ Download 05
Remote Debugging Connection:[ABATRON_SERIAL =l Edi Connestion._|
CF Debugger Setti... =
CF Exceptions ] 05 Image Path: I MI
+ CF Intermupt LI
Factory Settings | Fiewvert Import Panel... | Export Panel... |

QK | Cancel | Apply |

b. Use the Connection list box to specify CCS-SIM.

c. Click OK. The IDE completes the remote debugging setup, and the Target
Settings window closes.

3. From the main menu bar, select Project > Make. The IDE updates all files, links code
into the finished application, and displays any error messages or warnings in the
Errors & Warnings window.

NOTE  The Make command applies to all source files: the IDE opens them all, the
compiler generates object code, then the linker creates an executable file.
(The Compile command applies only to selected files. The Bring Up To Date
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command compiles all changed files, without linking.)
The Project window lets you view compiler progress, or stop the build.

4. This completes building your project. You are ready for the debugging procedure of
the next section.

Debug the Application

This section explains you how to test whether your application runs as you expect. Topics
include starting the debugger, setting a breakpoint, and viewing registers. Follow these
steps:

1. Set debugger preferences.

a. Select Edit > Target Settings, (where Target is the name of the current build
target). The Target Settings window appears.

b. From the Target Settings Panels list, select CF Debugger Settings. The CF
Debugger Settings panel moves to the front of the window, as Figure 3.8 shows.

Figure 3.8 The CF Debugger Settings Panel

i EM5208EYB Console Debug Settings [MyProj.mcp] EHE
IE Target Settings Panels ||E CF Debugger Settings

CiCsr PIED[_DCESSDI ;I Target Processor:|5208 VI Target DS:IBareBoard VI
e CAC++ Wamings
.. ColdFire Azsembler — v Use Target Initialization Fil

=~ Code Generation -

; E

i ColdFire Processor I{Pr0|ect}M52DSEVB_cfg &I
‘o Global Optimizations

= Linker

— v Use Memary Configuration Fil

> ELF Dizazzembler I{Proiect}M52DSEVB.mem Browse... |
i ColdFire Linker
(= Editar — Program D ownload Options
L Custom Keywards Init . [~ Werify Memary Wiites
nitial Launch Successive Runs
= Debugger
Debugger Settings Executable [v Executable [V
Femate Debugging Constant Data [v Constant Data [
Iitislized Data v Initislized Data [v
CF Exceptions Uriritilized Data [~ | Uninitislized Data [~
+ CF Intermupt -
‘. Diebugger PIC Setti... »

Factory Settingsl Frewert | Import Panel... | Export Panel... |

QK | Cancel | Apply |

c. Make sure that the Target Processor list box specifies 5208 (or the platform target
you have specified).

d. Make sure that the Target OS list box specifies BareBoard.
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e. Click OK. The IDE saves the debugger settings, and the Target Settings window
closes.

NOTE  The default target initialization and memory configuration files are in
subdirectory \E68K_Support\Initialization_ Files, of the
CodeWarrior installation directory.

2. From the IDE main menu, select Project > Debug. A progress bar appears as the
system downloads the output file to the target. The debugger starts; the Debugger
window (Figure 3.9) appears.

NOTE  For a ROM build target, you must load the application to Flash memory before
you can perform Step 2.

Figure 3.9 Debugger Window

i M5208EYE Console Debug.elf (Thread Dx0) =] B3

R E x o0 EHREE

Stack m| | [fe Variables: Live | Value | Location ]|
__start [0=400004DE) ;I = _files (0x400056E 4 (0x400056E 4 ;I
A4
Sourcer Chvmy_projectsbtyProfiS ourceimain. ¢ Ell

S =
* File: main.c
* Purpose: =zanple programn

*
*.7

#include <stdio. h:
int main()
- printf{"Hello World in Chns~r"):
- fflush({stdout):
- while{l): s Idle
return 0;

-

a. Note the toolbar at the tof) (;f the window; it includes command buttons Run, Stop,
Kill, Step Over, Step Into, and Step Out.

b. Note the Stack pane, at the upper left. This pane shows the function calling stack.

c. Note the Variables pane, at the upper right. This pane lists the names and values of
any local variables.
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d. Note the Source pane, the largest pane of the window. This pane displays C/C++
or assembly source code.

3. Set a breakpoint.

In the Source pane, find the line containing the open brace ( { ) character.

b. In the far left-hand column of this line, click the grey dash. A red circle replaces the
dash, indicating that the debugger set a breakpoint at the location. Figure 3.10
shows the red-circle indicator.

Figure 3.10 Setting a breakpoint

Breakpoint

4. View registers.

{ @M5208EYB Console Debug.elf {Thread 0x0) [_TO0]
50 x b OEE

[§ Stack 8| | [J# Variables: Live | Valus | Location ]|
__start [0x400004DE] ;I E- _files Ox40005664 Ox40005664 ;I
[] ]

e
SOUICEZ C:hmy_prajectsityProjhS ourcetmain.c [
x =

* File: mnain.c
#* Purpose
*

*
#include <stdioc.h>
int main()

e8]

fflush(=tdout):

- while(l): /- Idle
return 0:

-

© . Line 10 Coll | Souce GEl|

=zanple programn

- printf('Hella World in Cinse"):

;I_L

a. From the main menu bar, select View > Registers. The Registers window
(Figure 3.11) appears.

b. Use the expand controls to drill down through register categories to individual
registers — when you reach individual registers, their values appear at the right
side of the window.

You may edit register values directly in the Registers window.

d. Close the Registers window.

ColdFire Architectures v6.3 - Targeting Manual

29



Application Tutorial
Debug the Application

Figure 3.11 Registers Window

§ Register | alue |
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- WER 040000000
- RAMBARL 000000000
- OTHER_A7 0x30003FEC
- I5s Registers
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e CYCLCNT 1977 Y

5. View memory.

a. In the Source pane of the Debugger window, right-click on main. The view-
memory context menu (Figure 3.12) appears.

Figure 3.12 View Memory Context Menu

Find and ©pen File. ..

G0 ko Function definition of maind)

Preprocess

Set Software Breakpaint
Set Thread Specific Breakpoint

View As, .,

Wiew Yariable

Yiew Mernory

Yiew Memoary As...
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b. From this context menu, select View Memory. The View Memory window Figure

3.13 appears.

Figure 3.13 View Memory Window

{ @M5208EYB Console Debug.elf Memory 1 _ O x

Display: |mein
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c. Note that the View Memory window displays hexadecimal and ascii values for
several addresses, starting at the address of main.

d. In the Display text box, type a valid address in RAM or ROM.

e. Press the Enter key. Window contents change, to display memory values starting at
the address you entered.

NOTE

you disassemble a random part of memory.

f. Close the View Memory window.

6. Run the application.

You can edit the contents of the View Memory window. This window also lets
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a. From the main menu bar, select Project > Run, or click the Run button 5‘ of
the Debugger window. A console window (Figure 3.14) appears, displaying the
Hello-World-message result of the application.

Figure 3.14 Console Window

i mColdFire Console I/0
Hello World in C

-

kil 4

b. Click the Kill button ® of the Debugger window. The debugger stops the
application, the IDE stops the debugger, and the Debugger widow closes.

c. This completes the procedure — you have created and debugged a simple
application. You may close any open windows.
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This chapter explains the settings panels specific to ColdFire software development. Use
the elements of these panels to control assembling, compiling, linking, and other aspects
of code generation.

NOTE  For documentation of the target settings panels included in all CodeWarrior
products, see the IDE User Guide.

This chapter consists of these sections:

o Target Settings Overview

e ColdFire Settings Panels

Target Settings Overview

A CodeWarrior project contains one or more build targets. A build target is a named
collection of files and settings that the CodeWarrior IDE uses to generate an output file.

A build target contains all build-specific rarget settings. Target settings define:
» The files that belong to a build target.
* The behavior of the compiler, assembler, linker, and other build tools.

The build target feature lets you create different versions of your program for different
purposes. For example, you might have a debug build target. This build target would
include no optimizations so it is easy to debug. You might also have a release build target.
This build target would be heavily optimized so it uses less memory or runs faster.

You control target settings through target settings panels that you access through the
Target Settings window.

To open this window, select Edit > Target Settings, from the main-window menu bar.
(Target is a target name, such as CF_Simulator, within your CodeWarrior project.) An
alternate way to brig up the Target Settings window is to bring the Targets page to the
front of the project window, then double-click the project name.

Figure 4.1 shows this Target Settings window. (The CodeWarrior IDE User’s Guide
explains all elements of this window.)
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Use the tree listing of panels, in the Target Settings Panels pane, to display any settings
panel. If necessary, click the expand control to see a category’s list of panels. Clicking a
panel name immediately puts that panel in the Target Settings pane.

Figure 4.1 Target Settings Window

IE Target Settings Panels ||E Debugger Settings
C/C++ Preprocessor 2

— Location of Relocated Libraries and Code Resources

C/C++ W arnings
ColdFire Azzembler I Choose... |
= Code Generation
i ColdFire Processor — v Stop on application launch
- Global Optimizations .
= Linker P = Program entry point " Default language entry point
-~ ELF Disassembler & User specified:  [main
----- CaldFire Linker
= gEdltm — Other Settings
----- Custom Keywords o .
- Debugger [~ Auteetarget Libraries [V Cache symbolics between runs
v Log System Meszages v Stop at W atchpoints
IV Log System M IV Stop at watchpoi

™ Update data every |5 seconds  Conzole Encoding: INone 'l

CF Debugger Setti...
CF Exceptions

- CF Intermupt =
‘.. Diebugger PIC Setti... »

Factory Settings Frewert Import Panel... | Export Panel... |

QK | Cancel | Apply |

Note these buttons, at the bottom of the window:

¢ Apply — Implements your changes, leaving the Target Settings window open. This
lets you bring up a different settings panel.

¢ OK — Implements your changes, closing the Target Settings window. Use this
button when you make the last of your settings changes.

¢ Revert — Changes panel settings back to their most recently saved values.
(Moditying any panel settings activates this button.)

¢ Factory Settings — Restores the original default values for the panel.
¢ Import Panel — Copies panel settings previously saved as an XML file.

* Export Panel — Saves settings of the current panel to an XML file.

ColdFire Settings Panels

Table 4.1 lists the target settings panels specific to developing applications for the
ColdFire target. The following section describes these panels in detail.
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Table 4.1 ColdFire Target Settings Panels

Target Settings ColdFire Processor
BatchRunner PreLinker ELF Disassembler
BatchRunner PostLinker ColdFire Linker
ColdFire Target Debugger PIC Settings
ColdFire Assembler

NOTE  For debugger-specific panels CF Debugger Setting, CF Exceptions,
Debugger Settings, and Remote Debugging, see the Debugging chapter.
For information about the C/C++ Language and C/C++ Warnings panels,
see the C Compilers Reference manual.
For details on all other panels, see the IDE User’s Guide.

Target Settings

Use the Target Settings panel (Figure 4.2) to define the build target and select the
appropriate linker. Table 4.2 explains the elements of this panel.

NOTE  You must use this settings panel to select a linker before you can specify the
compiler, linker settings, or any other project details.

Figure 4.2 Target Settings Panel

H Target Settings

Target Marne: |M52‘I 3EWE Caonsole Debug

Linker:lEmbeu:Iu:Ieu:I ColdFire Linker

F're-linker:lNune
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DOutput Directany:
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Clear I

|{F'r0ieu:t}|:uin

[ Save project entries using relative paths
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Table 4.2 Target Settings Panel Elements

Element Purpose Comments
Target Name text Specifies the name of the build Default: None.
box target; this name appears

This build-target name is not

subsequently on the Targets the name of your final output

page of the project window.

file.
Linker list box Specifies the linker: Select Default: ColdFire.
ColdFire. Controls visibility of other
relevant panels.
Pre-linker list box Specifies the pre-linker that Default: None.

performs work on object code

before linking. If your project includes Flash

programming, select
BatchRunner PreLinker. For
more information, see
BatchRunner PreLinker.

Post-linker list box | Specifies the post-linker that Default: None.
performs additional work on the

final executable. Post-linking often includes

object code format
conversion. If your project
includes Flash programming,
select BatchRunner
PostLinker. For more
information, see BatchRunner

PostLinker.
Output Directory Specifies the directory for the Default: Directory that
text box final linked output file. To specify | contains the project file.
a non-default directory, click the
Choose button. To clear this
text box, click the Clear button.
Save project Clear — Specifies minimal file Default: Clear.
entries using searching; each project file must
relative paths have a unique name.
checkbox

Checked — Specifies relative
file searching; project may
include two or more files that
have the same name.
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BatchRunner PreLinker

The BatchRunner PreLinker settings panel (Figure 4.3) lets you run a batch file before
the IDE begins linking your project. To specify such a batch file, click the Choose button,

then use the subsequent dialog box to navigate to and select the file. Clicking the OK
button of the dialog box returns you to this panel, filling in the name of the batch file.

Figure 4.3 BatchRunner PreLinker Panel

R BEatchRunner PreLinker

Select the batch file o run before a link,
Batch file:

Crnd Window:lMinimize vI

BatchRunner PostLinker

Chooze. _. I
Clear I

The BatchRunner PostLinker settings panel (Figure 4.4) lets you run a batch file after
the IDE builds your project. To specify such a batch file, click the Choose button, then use
the subsequent dialog box to navigate to and select the file. Clicking the OK button of the

dialog box returns you to this panel, filling in the name of the batch file.

Figure 4.4 BatchRunner PostLinker Panel

R BatchRunner PostLinker

Select the batch file to run after the successiul link
Batch file:

—I Argument [Pass linker output file as %1 parameter to batch filg)
% Wame of the linker autput file
1 FullPath af the linker output file

Choose... I
Clear I

W arking Directany
{® Linker output dirsctany
" Batch file directory

Crnd Window:lMinimize VI

To pass the name of the output file as a parameter to the batch file, check the Pass linker

output file as %1 parameter to batch file checkbox.
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ColdFire Target

Use the ColdFire Target panel (Figure 4.5) to specify the type of project file and to name
your final output file. Table 4.3 explains the elements of this panel. (To create alternative
builds, compiling for different targets, use the __option () pre-processor function with
conditional compilation.)

Figure 4.5 ColdFire Target Panel

R Coldfire: Target |

Project Type: IAppIication - I

File: M arme: |M521 3EVE Console Debug.elf

Table 4.3 ColdFire Target Panel Elements

Element Purpose Comments

Project Type list box Specifies the kind of project: Default: Application.
Application — executable project
Library — static library

Shared Library — shared library

File Name text box Specifies the name of your final Default: None.

linked output file. Convention: use

extension.elf for an
application, .1ibor .a
for a library.

ColdFire Assembler

Use the ColdFire Assembler panel (Figure 4.6) to control the source format or syntax for
the CodeWarrior assembler, and to specify the target processor, for which you are
generating code. Table 4.4 explains the elements of this panel.
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Figure 4.6 ColdFire Assembler Panel

N ColdFire Aszembler

Proceszor: | 2
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¥ Processor has EMAL
¥ Processor has FPLU
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™ Generate Listing File
Prefix File: I

Table 4.4 ColdFire Assembler Panel Elements

multiply accumulator (MAC) unit.

Checked — Tells assembler that the
target processor does have a MAC.

Element Purpose Comments
Processor list box Specifies the target processor. Default: MCF52xx.
Processor has MAC Clear — Tells assembler that the Default: Clear.
checkbox target processor does not have a

You can check both
the MAC and
EMAC checkboxes.

Processor has EMAC Clear — Tells assembler that the
checkbox target processor does not have an
enhanced multiply accumulator
(EMAC) unit.

For more information, see the
reference manual at
{CodeWarrior_Dir}
\Freescale_Documentation,

Checked — Tells assembler that the
target processor does have EMAC.

Default: Clear.

You can check both
the MAC and
EMAC checkboxes.
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Table 4.4 ColdFire Assembler Panel Elements (continued)

Element

Purpose

Comments

Processor has FPU
checkbox

Clear — Tells assembler that the
target processor does not have a
floating-point unit (FPU).

Checked — Tells assembler that the
target processor does have an FPU.

Default: Clear

Labels Must End With
“’ checkbox

Clear — System does not require
labels to end with colons.

Checked — System does require
labels to end with colons.

Default: Checked.

Directives Begin With
‘.’ checkbox

Clear — System does not require
directives to start with periods.

Checked — System does require
directives to start with periods.

Default: Checked.

Case Sensitive
Identifiers checkbox

Clear — Tells assembler to ignore
case in identifiers.

Checked — Tells assembler to
consider case in identifiers.

Default: Checked.

Allow Space In
Operand Field
checkbox

Clear — Tells assembler to not allow
spaces in operand fields.

Checked — Tells assembler to allow
spaces in operand fields.

Default: Checked.
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Table 4.4 ColdFire Assembler Panel Elements (continued)

Element Purpose Comments
Generate Listing File Clear — Tells assembler to not Default: Clear.
checkbox generate a listing file. Alisting file
Checked — Tells assembler to contains the file
generate a listing file. source, along with
line numbers,
relocation

information, and
macro expansions.

Prefix File text box Specifies the name of the assembly Default: None.

prefix file. Useful for include

files that define
common constants,
global declarations,
and function
names. Otherwise,
the assembler’s
default prefix file
suffices.

ELF Disassembler

Use the ELF Disassembler panel (Figure 4.7) to control settings for the disassembly
view; you see this view when you disassemble object files. Table 4.5 explains the
elements of this panel.
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Figure 4.7 ELF Disassembler Panel
H ELF Disassembler

¥ Show Headers [ Werbose Info
¥ Show Symbol and String T ables ¥ Show Fielocations

— W Show Code Modules

¥ Use Extended Mremonics ¥ Show Source Code
¥ Show &ddresses and Object Code v Show Comments

— W Show Data Modules

[ Disassemble Exception Tables

[ Show Debug Info

Table 4.5 ELF Disassembler Panel Elements

Element Purpose Comments
Show Headers Clear — Keeps ELF header Default: Checked.
checkbox information out of the

disassembled output.

Checked — Puts ELF
header information into the
disassembled output.

Verbose Info Clear — Uses minimum Default: Clear.
checkbox information in disassembled )
output. For_the .s_ymtab s_ectlon,
additional information
Checked — Puts additional includes numeric equivalents
information into the for descriptive constants. For
disassembled output. the .1line, .debug, .extab,
and .extabindex sections,
additional information
includes an unstructured hex
dump.
Show Symbol and Clear — Keeps symbol table | Default: Checked.
String Tables out of the disassembled
checkbox module.

Checked — Puts symbol
table into the disassembled
module.
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Table 4.5 ELF Disassembler Panel Elements (continued)

Element

Purpose

Comments

Show Relocations
checkbox

Clear — Keeps relocation
information out of the
disassembled module.

Checked — Puts relocation
information into the
disassembled module.

Default: Checked.

Relocation information
pertains to the .real.text
and .reala.data sections.

Show Code Modules
checkbox

Clear — Keeps any of the
four types of ELF code
sections out the
disassembled module;
disables the four
subordinate checkboxes.

Checked — Activates the
four subordinate
checkboxes. For each
checked subordinate
checkbox, puts ELF code
section into the
disassembled module.

Default: Checked.

Use Extended
Mnemonics checkbox

Clear — Keeps extended
mnemonics out of the
disassembled module.

Checked — Puts instruction
extended mnemonics into
the disassembled module.

Default: Checked.

This checkbox is active only if
the Show Code Modules
checkbox is checked.

Show Source Code
checkbox

Clear — Keeps source code
out of the disassembled
module.

Checked — Lists source
code in the disassembled
module. Display is mixed
mode, with line-number
information from original C
source code.

Default: Checked.

This checkbox is active only if
the Show Code Modules
checkbox is checked.
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Table 4.5 ELF Disassembler Panel Elements (continued)

Element

Purpose

Comments

Show Addresses and
Object Code checkbox

Clear — Keeps addresses
and object code out of the
disassembled module.

Checked — Lists addresses
and object code in the
disassembled module.

Default: Checked.

This checkbox is active only if
the Show Code Modules
checkbox is checked.

Show Comments
checkbox

Clear — Keeps
disassembler comments out

of the disassembled module.

Checked — Shows
disassembler comments in
sections that have comment
columns.

Default: Checked.

This checkbox is active only if
the Show Code Modules
checkbox is checked.

Show Data Modules
checkbox

Clear — Blocks output of
ELF data sections for the
disassembled module;
disables the Disassemble
Exception Tables checkbox.

Checked — Outputs
.rodata, .bss, or other
such ELF data sections in
the disassembled module.
Activates the Disassemble
Exception Tables checkbox.

Default: Checked.

Disassemble
Exception Tables
checkbox

Clear — Keeps C++
exception tables out of the
disassembled module.

Checked — Includes C++
exception tables in the
disassembled module.

Default: Clear.

This checkbox is active only if
the Show Data Modules
checkbox is checked.

Show Debug Info
checkbox

Clear — Keeps DWARF
symbolics out of the
disassembled module.

Checked — Includes
DWARF symbolics in the
disassembled module.

Default: Clear.
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ColdFire Processor

Use the ColdFire Processor panel (Figure 4.8) to control code-generation settings. Table
4.6 explains the elements of this panel.

Figure 4.8 ColdFire Processor Panel
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Table 4.6 ColdFire Processor Panel Elements

Element

Purpose

Comments

Target CPU list
box

Specifies the target ColdFire
processor.

Default: MCF5282.

Code Model list
box

Specifies access addressing for
data and instructions in the object
code:

Smart — Relative (16-bit) for
function calls in the same
segment; otherwise absolute (32-
bit).

Near (16 bit) — Relative for all
function calls.

Far (32 bit) — Absolute for all
function calls.

Default: Far (32 bit).

Far is useful if your source

file generates more than 32K
of code, or if there is an out-
of-range link error message.

Near requires adjusting the
.1cf. For . 1cf information,
see the ColdFire Build Tools
Reference manual.
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Table 4.6 ColdFire Processor Panel Elements (continued)

Element

Purpose

Comments

Struct Alignment
list box

Specifies record and structure
alignment in memory:

68K 2-byte — Aligns all fields on
2-byte boundaries, except for
fields of only 1 byte.

68K 4-byte — Aligns all fields on
4-byte boundaries.

PowerPC 1-byte — Aligns each
field on its natural boundary.

Default: 68k 4-byte.

This panel element
corresponds tothe options
align pragma.

Natural-boundary alignment
means 1-byte for a 1-byte
character, 2-bytes for a 16-
bit integer, and so on.

NOTE: When you compile
and link, alignment should
be the same for all files and
libraries.

Data Model list
box

Specifies global-data storage and
reference:

Far (32 bit) — Storage in far data
space; available memory is the
only size limit.

Near (16 bit) — Storage in near
data space; size limit is 64K.

Default: Far (32 bit).

This panel element
corresponds the far_data
pragma.

Parameter
Passing list box

Specifies parameter-passing level:

Compact — Passes on even-sized
boundary for parameters smaller
than int (2 for short and char).

Standard — Like compact, but
always padded to 4 bytes.

Register — Passes in scratch
registers DO — D2 for integers, AO
— A1 for pointers and fp0 — fp1
when FPU codegen is selected;
this can speed up programs that
have many small functions.

Default: Compact.

These levels correspond to
the compact_abi,
standard_abi, and
register_abi pragmas.

NOTE: Be sure that all called
functions have prototypes.
When you compile and link,
parameter passing should
be the same for all files and
libraries.
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Table 4.6 ColdFire Processor Panel Elements (continued)

Element Purpose Comments
Floating Point list Specifies handling method for Default: Software.
box floating-point operations:

For software selection, your
Software — C runtime library code | project must include the
emulates floating-point operations. | appropriate FP_ColdFire

Hardware — Processor hardware C runtime library file.

performs floating point operations; Greyed out if your target
only appropriate for processors processor lacks an FPU.
that have floating-point units.

4-Byte Integers Clear — Specifies 2-byte integers. | Default: Checked.

checkbox Checked — Specifies 4-byte

integers.
Position- Clear — Generates relocatable Default: Clear.
Independent code.

PIC is available with 16- and
Checked — Generates position- 32-bit addressing.
independent code (PIC) that is
non-relocatable.

Code checkbox

A6 Stack Frames Clear — Disables call-stack Default: Checked.
checkbox tracing; generates faster and

Checking this checkbox
smaller code.

corresponds to using the
Checked — Enables call-stack a6frames pragma.
tracing; each stack frame sets up
and restores register A6.

Position- Clear — Generates relocatable Default: Clear.

IndependentData | data. PID is available with 16- and

checkbox Checked — Generates position- 32-bit addressing.
independent data (PID) that is
non-relocatable.

Emit Macsbug Clear — Does not generate Default: Clear.

(S:Kg;bkglsx Macsbug symbols. A Macsbug symbol is the
Checked — Generates Macsbug routine name, appended
symbols inside code after RTS after the routine, in Pascal
statements. format. These symbols are

appropriate only for older
debuggers.
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Table 4.6 ColdFire Processor Panel Elements (continued)

Element

Purpose

Comments

PC-Relative
Strings checkbox

Clear — Does not use program-
counter relative addressing for
storage of function local strings.

Checked — Does use program-
counter relative addressing for
storage of function local strings.

Default: Clear.

Checking this box
corresponds to using the
pcrelstrings pragma.

Generate code
for profiling

Checked — Has the processor
generate code for use with a
profiling tool.

Clear — Prevents the processor
from generating code for use with
a profiling tool.

Default: Clear.

Checking this box
corresponds to using the
command-line option
-profile.

Clearing this checkbox is
equivalent to using the
command-line option
-noprofile

Use .sdata/.sbss
for area

All data — Select this option
button to store all data items in the
small data address space.

All data smaller than — Select this
option button to specify the
maximum size for items stored in
the small data address space;
enter the maximum size in the text
box.

Default: All data smaller
than/0.

Using the small data area
speeds data access, but has
ramifications for the
hardware memory map. The
default settings specify not
using the small data area.

ColdFire Linker

Use the ColdFire Linker panel (Figure 4.9) to control the final form of your object code.
Table 4.7 explains the elements of this panel.
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Figure 4.9 ColdFire Linker Panel
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Table 4.7 ColdFire Linker Panel Elements

Element Purpose Comments
Generate Clear — Does not generate | Default: Checked.
Symbolic Info debugging information in
checkbox the output ELF file.

Checked — Puts generated
debugging information into
the output ELF file.

Store Full Path
Names checkbox

Clear — In debugging
information in the linked
ELF file, uses only names of
source files.

Checked — Includes
source-file paths in the
debugging information in
the linked ELF file.

Default: Checked.

Clearing this checkbox saves target
memory, but increases the time the
debugger needs to find the source
files.
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Table 4.7 ColdFire Linker Panel Elements (continued)

Element

Purpose

Comments

Generate Link

Clear — Does not generate

Default: Checked.

Map checkbox a link map. A link map includes addresses of all
Checked — Does generate objects and functions, a memory
a link map (a text file that map of sections, and values of
identifies definition files for symbols the linker generates. A link
each object and function of map has the same filename as the
your output file); activates output file, but with extension
the List Unused Objects and . XMAP.
Show Transitive Closure
checkboxes.
List Unused Clear — Does not include Default: Clear.
Objects unused objects in the fink This checkbox is active only if the
checkbox map.

Checked — Does include
unused objects in the link
map.

Generate Link Map checkbox is
checked.

NOTE: The linker never deadstrips
unused assembler relocatables or
relocatables built with a non-
CodeWarrior compiler. But
checking this checkbox gives you a
list of such unused items; you can
use this list to remove the symbols.

Show Transitive
Closure

Clear — Does notinclude
the link map objects that

Default: Checked.

This checkbox is active only if the

checkbox main () references. Generate Link Map checkbox is
Checked — Recursively checked. Listings after this table
lists in the link map all show the effect of this checkbox.
objects that main ()
references.

Disable Clear — Lets linker remove Default: Clear.

Deadstripping unused code and data.

checkbox

Checked — Prevents the
linker from removing
unused code or data.
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Table 4.7 ColdFire Linker Panel Elements (continued)

Element

Purpose

Comments

Generate ELF

Clear — Omits the ELF

Default: Checked.

Symbol Table symbol table and relocation
checkbox list from the ELF output file.

Checked — Includes an

ELF symbol table and

relocation list in the ELF

output file.
Suppress Clear — Reports all linker Default: Clear.
Warning warnings.
Messages Checked — Reports only
checkbox .

fatal warning messages;

does not affect display of

messages from other parts

of the IDE.
Generate S- Clear — Does not generate | Default: Checked.
Record File an S-record file. The S-record has the same
checkbox

Checked — Generates an
S3-type S-record file,
suitable for printing or
transportation to another
computer system. Activates
the Max S-Record text box
and the EOL character list
box.

filename as the executable file, but
with extension .s19, .S3 records
include code, data, and their 4-byte
addresses.

Max S-Record
Length text box

Specifies maximum number
of bytes in S-record lines
that the linker generates.
The maximum value for this
text box is 252.

Default: 80.

This text box is active only if the
Generate S-Record File checkbox
is checked.

NOTE: Many embedded systems
limit S-record lines to 24 or 26
bytes. A value of 20 to 30 bytes lets
you see the S-record on a single

page.

EOL Character
list box

Specifies the end-of-line
character for the S-record
file, by operating system:
DOS, UNIX, or MAC.

Default: DOS.

This text box is active only if the
Generate S-Record File checkbox
is checked.
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Table 4.7 ColdFire Linker Panel Elements (continued)

Element

Purpose

Comments

Generate Binary
Image checkbox

Clear — Does not create a
binary version of the S-
record file.

Checked — Saves a binary
version of the S-record file
to the project folder; The
binary file has the .b
filename extension.
Activates the Max Bin
Record Length text box.

Default: Clear.

Binary file format is address (4
bytes), byte count (4 bytes), and
data bytes (variable length).

Max Bin Record
Length text box

Specifies data-byte length
for each binary record. The
maximum value is 252.

Default: None.

This text box is active only if the
Generate Binary Image checkbox is
checked.

Entry Point text
box

Specifies the program
starting point: the first
function the debugger uses
upon program start.

Default: __start.

(This default function is in file
ColdFire__ startup.c. It sets
up the ColdFire EABI environment
before code execution. Its final task
is callingmain ().

Force Active
Symbols text box

Specifies symbols to be
included in the output file
even if not referenced;
makes such symbols
immune from deadstripping.

Default: None.

Use spaces to separate multiples
symbols.

Listing 4.1 and Listing 4.2 show the effect of the Show Transitive Closure checkbox.

Listing 4.1 Sample Code for Transitive Closure

void alphal () {
int a = 1001;

}
void alpha () {
int b = 1002;
alphal();
}
int main(void) {
alpha () ;
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return 1;

If you checked the Show Transitive Closure checkbox of the ColdFire Linker panel and
compiled the source files,

¢ The linker would generate a link map file, and

¢ The link map file would include text such as that of Listing 4.2.

Listing 4.2 Link Map: Effects of Show Transitive Closure

# Link map of __ start
1] _ _start (func, global) found in C_4i_CF_Runtime.a E68k_startup.o
2] _ _main (func, global) found in main.c
3] __alpha (func, global) found in main.c
4] _ _alphal (func, global) found in main.c

Debugger PIC Settings

Use the Debugger PIC Settings panel (Figure 4.10) to specify an alternate address where
you want your ELF image downloaded on the target.

Figure 4.10 Debugger PIC Settings Panel
N Debugger PIC Settings

[~ Alernate Load Address
Lmnnnnnnnn

Usually, Position Independent Code (PIC) is linked so that the entire image starts at
address 0x00000000. To specify a different target address for loading the PIC module:

1. Check the Alternate Load Address checkbox — this activates the text box.
2. Enter the address in the text box.
At download time, the debugger downloads your ELF file to this new address of the target.

NOTE  The debugger does not verify that your code can execute at the new address.
However, the PIC generation settings of the compiler and linker, and the
startup routines of your code, correctly set any base registers and perform any
appropriate relocations.
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This chapter explains aspects of debugging that are specific to the ColdFire architectures.
For more general information about the CodeWarrior debugger, see the IDE 5.7 User’s
Guide.

To start the CodeWarrior debugger, select Project > Debug. The debugger window
appears; the debugger loads the image file that the current build target produces. You can
use the debugger to control program execution, insert breakpoints, and examine memory
and registers.

NOTE  The automatic loading of the previous paragraph depends on the load options
you specity, and on whether your application code is in ROM or Flash
memory.

This chapter consists of these sections:
» Target Settings for Debugging
¢ Remote Connections for Debugging
* BDM Debugging
* Debugging ELF Files without Projects
* Special Debugger Features

Target Settings for Debugging

Several target settings panels control the way the debugger works:

¢ CF Debugger Settings Panel
* Remote Debugging Panel
* CF Exceptions Panel

¢ Debugger Settings Panel

¢ CF Interrupt Panel

To access these panels, select Edit > Target Settings, from the main menu bar. (Target
is the current build target in the CodeWarrior project.) The Target Settings window
(Figure 5.1) appears.
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Figure 5.1 Target Settings Window
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Table 5.1 lists additional panels that can affect debugging.

Table 5.1 Additional Settings Panels That May Affect Debugging

Panel Impact See
C/C++ Warnings compiler warnings C Compilers Reference
ColdFire Linker controls symbolics, ColdFire Linker

linker warnings

ColdFire Processor optimizations ColdFire Processor

Global Optimizations optimizations IDE User’s Guide

CF Debugger Settings Panel

Use the CF Debugger Settings panel (Figure 5.2) to select debugger hardware and
control interaction with the target board. Table 5.2 explains the elements of this panel.
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Figure 5.2 CF Debugger Settings Panel
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Table 5.2 CF Debugger Settings Panel Elements

Element

Purpose

Comments

Target
Processor list
box

Specifies the target processor.

Your stationery selection automatically makes
this specification.

Target OS list
box

Specifies a real-time operating
system; for bare board
development, select BareBoard.

Default: BareBoard.

If you have Professional-Edition software and
install an RTOS, that RTOS becomes a
selection of this list box. (Special- and
Standard-Edition software, however, does not
support an RTOS.)

Use Target
Initialization File
checkbox

Clear — Specifies not using a
target initialization file; deactivates
file subordinate text box and
Browse button.

Checked — Tells the debugger to
use the specified target
initialization file. To enter a
pathname in the text box, click the
Browse button, then use the file-
select dialog box to specify the
file.

Default: checked.

The initialization file is in subdirectory
\E68K_Support\Initialization_Files
, of the CodeWarrior installation directory (or
directory that contains your project).

Clear this checkbox, if you are using an
Abatron-based remote connection.

Make sure this checkbox is checked, if you
are using a P&E Micro-based remote
connection.
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Table 5.2 CF Debugger Settings Panel Elements (continued)

Element Purpose Comments
Use Memory Clear — Specifies not using a Default: Unchecked.
Configuration memory configuration file; The memory configuration file is in

File checkbox

deactivates file subordinate text
box and Browse button.

Checked — Tells the debugger to
use the specified memory
configuration file. To enter a
pathname in the text box, click the
Browse button, then use the file-
select dialog box to specify the
file.

subdirectory
\E68K_Support\Initialization_Files
, of the CodeWarrior installation directory (or
directory that contains your project).

Do not check this checkbox, if you are using a
Abatron-based remote connection.

Check this checkbox, if you are using a P&E
Micro-based remote connection.

Initial Launch: Clear — Does not download Default: Checked.
Executable program executable code or text Initial launch is the first time you debug the
checkbox sections for initial launch. project after you start the debugger from the
Checked — Downloads program IDE.
executable code and text sections
for initial launch.
Initial Launch: Clear — Does not download Default: Checked.
Constant Data program constant data sections Initial launch is the first time you debug the
checkbox for initial launch. project after you start the debugger from the
Checked — Downloads program IDE.
constant data sections for initial
launch.
Initial Launch: Clear — Does not download Default: Checked.
Initialized Data program initialized data sections Initial launch is the first time you debug the
checkbox for initial launch. project after you start the debugger from the
Checked — Downloads program IDE.
initialized data sections for initial
launch.
Initial Launch: Clear — Does not download Default: Clear.
Uninitialized program uninitialized data Initial launch is the first time you debug the

Data checkbox

sections for initial launch.

Checked — Downloads program
uninitialized data sections for
initial launch.

project after you start the debugger from the
IDE.
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Table 5.2 CF Debugger Settings Panel Elements (continued)

Element Purpose Comments
Successive Clear — Does not download Default: Clear.
Runs: program executable code or text Successive runs are debugging actions after
Executable sections for successive runs. initial launch. Note that rebuilding the project
checkbox Checked — Downloads program returns you to the initial-launch state.
executable code and text sections
for successive runs.
Successive Clear — Does not download Default: Clear.

Runs: Constant
Data checkbox

program constant data sections
for successive runs.

Checked — Downloads program
constant data sections for
successive runs.

Successive runs are debugging actions after
initial launch. Note that rebuilding the project
returns you to the initial-launch state.

NOTE: If you check this checkbox, avoid
cycling board power. Doing so can prevent
application rebuilding and code reloading,
making debugging unnecessarily difficult.

Successive
Runs: Initialized
Data checkbox

Clear — Does not download
program initialized data sections
for successive runs.

Checked — Downloads program
initialized data sections for
successive runs.

Default: Checked.

Successive runs are debugging actions after
initial launch. Note that rebuilding the project
returns you to the initial-launch state.

Successive
Runs:
Uninitialized
Data checkbox

Clear — Does not download
program uninitialized data
sections for successive runs.

Checked — Downloads program
uninitialized data sections for
successive runs.

Default: Checked.

Successive runs are debugging actions after
initial launch. Note that rebuilding the project
returns you to the initial-launch state.

Verify Memory
Writes
checkbox

Clear — Does not confirm that a
section written to the target
matches the original section.

Checked — Confirms that any
section written to the target
matches the original section.

Default: Clear.

Remote Debugging Panel

Use the Remote Debugging panel (Figure 5.3) to set up connections for remote

debugging. Table 5.3 explains the elements of this panel. Text following the figure and

table provides more information about adding and changing remote connections.
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NOTE

Special-Edition software supports the following remote connections: P&E

Microsystems USB, P&E Microsystems Cyclone Max, and Freescale USB
TAP. Standard-Edition software supports only P&E Microsystems USB

remote connection. For any

other type of remote connection, you must have

Professional-Edition software.

Figure 5.3 Remote Debugging Panel
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Table 5.3 Remote Debugging Panel Elements

Element Purpose Comments

Connection | Specifies the remote-connection Possible remote connections

list box type: the remote debugger, along include Abatron Serial or TCP/

with its default settings. IP; CCS-SIM; and P&E

Microsystems Parallel, USB,
Cyclone Max, and Lightning,
and Freescale USB TAP.
However, you must add any
such additional connection
before it is available in this list
box.

Edit Starts process of adding a remote For instructions, see text after

Connection | connection, or changing settings of this table.

button an existing remote connection.
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Table 5.3 Remote Debugging Panel Elements (continued)

Element

Purpose

Comments

Remote
download
text box

Specifies the absolute path to the
directory in which to store
downloaded files.

This option does not apply to
bareboard development.

Default: None.

Launch
remote host
application
checkbox

Clear — Prevents the IDE from
starting a host application on the
remote computer.

Checked — IDE starts a host
application on the remote computer.
(Also enables the corresponding text
box, for the absolute path to the
remote host application:)

This option does not apply to
bareboard development.

Default: Clear

Download
(O]
checkbox

Clear — Prevents downloading a
bootable image to the target system.
Checked — Downloads the specified
bootable image to the target system.
(Also enables the Connection list box
and OS Image Path text box.)

Default: Clear

Connection
list box

Specifies the remote-connection type
for downloading the bootable image
to the target board.

Disabled if the Download OS
checkbox is clear.

Lists only the remote
connections you add via the
Remote Connections panel.

OS Image
path

Specifies the host-side path of the
bootable image to be downloaded to
the target board.

Disabled if the Download OS
checkbox is clear.

Adding Remote Connections

NOTE  Special-Edition software supports the following remote connections: P&E
Microsystems USB, P&E Microsystems Cyclone Max, and Freescale USB
TAP. Standard-Edition software supports only P&E Microsystems USB
remote connection. For any other type of remote connection, you must have
Professional-Edition software.
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To add a remote connection, use the Remote Connections panel:
1. Select Edit > Preferences. The IDE Preferences window appears.

2. From the IDE Preferences Panels list, select Remote Connections. The Remote
Connections panel moves to the front of the IDE Preferences window. Figure 5.4
shows the IDE Preferences window at this point.

Figure 5.4 IDE Preferences Window: Remote Connections Panel
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3. Click the Add button. The New Connection dialog box (Figure 5.5) appears.

Figure 5.5 New Connection Dialog Box
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4. Inthe Name text box, enter a name for the new connection.
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5. Use the Debugger list box to specify the debugger for the new remote connection:
ColdFire Abatron, ColdFire P&E Micro, or ColdFire CCS (the simulator and USB
TAP).

6. Check the Show in processes list checkbox to add this new connection to the official
list. (To see this list of processes, select View > Systems > List.) Checking this
checkbox also adds this new connection to the remote-connection list that pops up
when you debug certain kinds of files.)

7. Use the Connection Type list box to specify the type — the remaining fields of the
dialog box change appropriately.

8. Use the remaining fields of the New Connection dialog box to make any appropriate
changes to the default values for connection type, port, rate, and so forth.

9. Click OK. The dialog box closes; the Remote Connections panel window displays
the new connection.

10. This completes adding the new connection. You may close the IDE Preferences
window.

Changing Remote Connections

To change to an already-configured remote connection, use the Remote Debugging panel
(Figure 5.3):

1. Click the arrow symbol of the Connection list box. The list of connections appears.
2. Select another connection. The list collapses; the list box displays your selection.

3. Click the Edit Connections button. A dialog box appears, showing the configuration
of the remote connection.

4. Use the dialog box to make any appropriate configuration changes.

5. Click OK. The dialog box closes, confirming your configuration changes.

NOTE  Any changes you make using the Remote Debugging panel apply to all targets
that use the specified connection.

CF Exceptions Panel

The CF Exceptions panel (Figure 5.6) is available with P&E Microsystems, simulator,
and Freescale USB TAP remote connections. Use this panel to specify hardware
exceptions that the debugger should catch. Table 5.4 explains the elements of this panel.

Before you load and run the program, the debugger inserts its own exception vector for
each exception you check in this panel. To use your own exception vectors instead, you
should clear the corresponding checkboxes.
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If you check any boxes, the debugger reads the Vector_Based_Register (VBR), finds the
corresponding existing exception vector, then writes a new vector at that register location.
The address of this new vector is offset 0x408 from the VBR address. For example, if the

VBR address is 0x0000 0000, the new vector at address 0x0000 0408 covers the checked
exceptions.

The debugger writes a Halt instruction and a Return from Exception instruction at this
same location.

NOTE  If your exceptions are in Flash or ROM, do not check any boxes of the CF
Exceptions panel.
Abatron remote connections ignore this panel, using instead the exception
definitions in the Abatron firmware.

Figure 5.6 CF Exceptions Panel

H CF Exceptions

Esception Handling [checked exceptions will have their vectors avernaritten ta allow a
debugger break when they ocour]

W 2Acocess Emar W 12 Non-PC breakpaint debug interupt
v 3 aAddress Emor [ 12 PC breakpoint debug intermupt

v 4 lllegal Instruction * [ 14 Format Errar

[V 5 Divide by zero v 15 Uninitialized Interupt

¥ 8 Privilege iolation v 24 Spurious |ntermupt

¥ 9Trace v 31IRO7 - break button *

v 10 Unimplemented Line-2 Opcode v 46 TRAP #14 for Conzale 140

¥ 11 Unimplemented Line-F Dpcode [ &1 Unsupported instruction

* - If unzelected theze may effect the debuggers ability to contral the target

Table 5.4 CF Exceptions Panel Elements

Element Purpose Comments
2 Access Error Clear — Ignores access errors. Default: Checked
checkbox Checked — Catches and displays access

errors.
3 Address Error | Clear — Ignores address errors. Default: Checked
checkbox Checked — Catches and displays address

errors.
4 lllegal Clear — Ignores invalid instructions. Default: Checked
Instruction Checked — Catches and displays invalid
checkbox instructions.
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Table 5.4 CF Exceptions Panel Elements (continued)

Element Purpose Comments

5 Divide by zero | Clear — Ignores an attempt to divide by zero. | Default: Checked
checkbox Checked — Catches and displays any
attempt to divide by zero.

8 Privilege Clear — Ignores privilege violations. Default: Checked
Violation Checked — Catches and displays privilege

checkbox violations.

10 Clear — Ignores unimplemented line-A Default: Checked

Unimplemented | opcodes.
Line-A Opcode Checked — Catches and displays
checkbox unimplemented line-A opcodes.

11 Clear — Ignores unimplemented line-F Default: Checked
Unimplemented | opcodes.
Line-F Opcode Checked — Catches and displays

checkbox unimplemented line-F opcodes.
12 Non-PC Clear — Ignores non-PC breakpoint debug Default: Checked
breakpoint interrupts.
debug interrupt Checked — Catches and displays non-PC
checkbox breakpoint debug interrupts.
13 PC Clear — Ignores PC breakpoint debug Default: Clear
breakpoint interrupts.
debug interrupt Checked — Catches and displays PC
checkbox breakpoint debug interrupts.
14 Format Error | Clear — Ignores format errors. Default: Checked
checkbox Checked — Catches and displays format
errors.
15 Uninitialized Clear — Ignores uninitialized interrupts. Default: Checked
Interrupt Checked — Catches and displays
checkbox uninitialized interrupts.
24 Spurious Clear — Ignores spurious interrupts. Default: Checked
Interrupt Checked — Catches and displays spurious
checkbox interrupts.
31IRQ7 - break | Clear — Ignores use of the IRQ7 break Default: Checked
button button.
checkbox Checked — Catches and displays uses of

the IRQ7 break button.
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Table 5.4 CF Exceptions Panel Elements (continued)

Element Purpose Comments
46 TRAP #14 Clear — Ignores trap 14 for console I/O. Default: Clear.
for Console I/0 Checked — Catches and displays uses of

checkbox trap 14 for console I/O.

61 Unsupported | Clear — Ignores unsupported instructions. Default: Clear.
instruction Checked — Catches and displays

checkbox unsupported instructions.

Debugger Settings Panel

Use the Debugger Settings panel (Figure 5.7) to select and control the debug agent. Table
5.5 explains the elements of this panel.

Figure 5.7 Debugger Settings Panel

N Debuager Settings

r Location of Relocated Libraries and Code Resources

I Choosze. . I

— v Stop on application launch

¢~ Program entry point " Default language entry point

& User specified:  |main

— Other Settingz
[ &uto-target Libraries ¥ Cache symbolics between runs
¥ Log System Messages ¥ Stop at ‘W atchpoints

[ Update data every |5 seconds  Congsole Encoding: INDne vI
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Table 5.5 Debugger Settings Panel Elements

Libraries and
Code Resources

Element Purpose Comments
Location of Specifies the pathname of Default: None
Relocated libraries or other resources

related to the project. Type the
pathname into this text box.

launch checkbox

text box Alternatively, click the Choose

button, then use the subsequent

dialog box to specify the

pathname.
Stop on Clear — Does not specify any Default: Checked, with Default
application debugging entry point; language entry point option

deactivates the subordinate
options buttons and text box.
Checked — Specifies the
debugging entry point, via a
subordinate option button:
Program entry point, Default
language entry point, or User
specified.

button selected.

If you select the User specified
option button, type the entry
point in the corresponding text
box.

Auto-target

Clear — Does not use auto-

Default: Clear

every checkbox

Libraries target libraries.
checkbox Checked — Uses auto-target
libraries.
Log System Clear — Does not log system Default: Checked
Messages messages.
checkbox Checked — Logs system
messages.
Update data Clear — Does not update data; Default: Clear

deactivates the subordinate text
box.

Checked — Regularly updates
data; enter the number of
seconds in the subordinate text
box.

Cache
symbolics
between runs
checkbox

Clear — Does not store symbolic
values in cache memory
between runs.

Checked — After each run,
stores symbolic values in cache
memory.

Default: Checked
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Table 5.5 Debugger Settings Panel Elements (continued)

Element Purpose Comments
Stop at Clear — Does not stop at Default: Checked
Watchpoints watchpoints.
checkbox Checked — Stops at

watchpoints.
Console Specifies the type of console Default: None
Encoding list encoding.
box

CF Interrupt Panel

Debugging an application involves single-stepping through code. But if you do not modify
interrupts that are part of normal code execution, the debugger could jump to interrupt-
handler code, instead of stepping to the next instruction.

So before you start debugging, you must mask some interrupt levels, according to your
processor. To do so, use the CF Interrupt panel (Figure 5.8); Table 5.6 explains the
elements of this panel.

Figure 5.8 CF Interrupt Panel
H CF Interupt

’7|7 Mask Interupts

Interrupt Levellw VI

Table 5.6 CF Interrupt Panel Elements

Element Purpose Comments
Mask Interrupts Clear — Ignores interrupts. Default: Clear.
checkbox Checked — Masks interrupts of

the specified and lower levels,
but allows higher-level interrupts.

Interrupt Level Specifies the interrupt level, from Default: 0.
list box 0 (low) to 7 (high).
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NOTE  The exact definitions of interrupt levels are different for each target processor,
and masking all interrupts can cause inappropriate processor behavior. This
means that finding the best interrupt level to mask can involve trial and error.

Be alert for any code statements that change the interrupt mask: stepping over
such a statement can modify your settings in this panel.

Remote Connections for Debugging

To debug an application on the remote target system, you must use a remote connection.

A remote connection is the physical connection from the host to the target board, together
with the settings that describe how the CodeWarrior IDE should connect to and control
program execution on target boards or systems. The remote connection includes the
debugger protocol, connection type, and connection parameters the IDE should use when
it connects to the target system. This section shows you how to access remote connections
in the CodeWarrior IDE, and describes the various debugger protocols and connection
types the IDE supports.

NOTE  We have included several types of remote connections in the default
CodeWarrior installation. You can modify these default remote connections to
suit your particular needs.

TIP  When you import a Makefile into the CodeWarrior IDE to create a CodeWarrior
project, the IDE asks you to specify the type of debugger interface (remote
connection) you want to use. To debug the generated CodeWarrior project, you
must properly configure the remote connection you selected when you created the
project.

For Special- and Standard-Edition software, the ColdFire debugger uses a plug-in
architecture to support the P&E Microsystems Parallel and USB remote-connection
protocols.

For Professional-Edition software, the ColdFire debugger uses a plug-in architecture to
support any of these remote-connection protocols:

* Abatron Serial

¢ Abatron TCP-IP

* Freescale USB-TAP

¢ P&E Microsystems Parallel
¢ P&E Microsystems USB
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* P&E Microsystems Lightning

¢ P&E Microsystems Cyclone MAX Serial
P&E Microsystems Cyclone MAX TCP-IP
P&E Microsystems Cyclone MAX USB
Simulator (CCS-SIM)

NOTE In addition to the protocols mentioned above, Code Warrior for ColdFire now
also allows use of additional run control devices through the GDI protocol. For
hardware interfaces which use the GDI protocol, please refer to the user's
manual of that particular interface for installation procedures. As interfaces
which use the GDI protocol make use of proprietary DLL files, Freescale does
not offer support for capabilities of a particular interface or guarantee
functionality. Please contact your interface supplier for any support questions.

Before you debug a project, you must configure or modify the settings of your remote-
connection protocol. Follow these steps:

1. From the main menu bar, select Edit > Target Settings. The Target Settings window
appears.

2. Select Target Settings Panels > Debugger > Remote Debugging. The Remote
Debugging panel moves to the front of the window.

3. Use the Connection list box to specify a remote connection. The supported list of
remote connections is shown in Figure 5.9.
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Figure 5.9 Connection List selection panel

i @M5208EYE Console Debug Settings [MyProj.mcp]

IE Target Settings Panels

| IE Fiemote Debugging

= Language Settings

i C/C++ Language
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|
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Connection: [FREESCALE_LISE-TAP

[

— Remate dofBATRON_SERIAL
WBATROM_TCP-IP
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= Code Generation CC5-S1k
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Remote Debugaing =
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QK | Cancel | Apply |

4. Click the Edit Connection button. A corresponding remote connection dialog box
appears.

5. Use the dialog box to input communication settings, according to text below.

Abatron Remote Connections

Figure 5.10 shows the configuration dialog box for an Abatron serial remote connection.
Figure 5.11 show the configuration dialog box for an Abatron TCP/IP remote connection.
Table 5.6 explains the elements of these dialog boxes.

Figure 5.10 Serial Abatron Remote-Connection Dialog Box

Marne: |AB_selial_new_connection

Debuggel:|CoIdFire Abatron = l
— Connection T_l,lpe:ISeriaI vl

[~ Showin processzes list

Port:ICEIM‘I vl F'aril_l,l:INone j
Hate:|1152DD vl Stap Bits:|1 |
j

Data Bits:IS vl

[ Log Communications D ata to Log ‘Window

Flaw Contml:lNone

ColdFire Architectures v6.3 - Targeting Manual 71



Debugging

Remote Connections for Debugging

Figure 5.11 TCP/IP Abatron Remote-Connection Dialog Box

I arne: |AB_TEP|_new_connecti0n

Debugger:ICoIdFire Abatron l
Connection T_l,lpe:ITCF'.fIF' vl

[T Shaowin proceszes list

IP Address: I

Enter an IP address in the format of 127.0.0.1:1000 or host. domain.com:1000.

" Log Communications Data to Log windaw

Table 5.7 Abatron Dialog-Box Elements

Element

Purpose

Comments

Name text box

Identifies the remote connection.

For an existing connection,
already has a value.

Debugger list

Identifies the debugger.

For an existing connection,

1200, 2400, 9600, 9,200, 38,400,
57,600, 115,200, or 230,400
baud.

box already specifies ColdFire
Abatron
Show in Clear — Leaves the connection Default: Clear
processes list off the official list.
checkbox Checked — Adds connection to
the official list (select View >
Systems > List); also adds
connection to the pop-up list for
debugging certain kinds of file.
Connection Specifies serial or TCP/IP. Changing this value changes
Type list box the subordinate elements of
the dialog box, as Figure 5.10
and Figure 5.11 show.
Port list box Specifies the serial port: COM1, Default: COM1.
COM2, COM3, ... or COM256.
Rate list box Specifies transfer speed: 300, Default: 38,400 baud

Data Bits list box

Specifies number of data bits per
character: 4, 5, 6, 7, or 8.

Default: 8
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Table 5.7 Abatron Dialog-Box Elements (continued)

Parity list box

Specifies parity type: None, Odd,
or Even.

Default: None

Stop Bits list box

Specifies number of stop bits: 1,
1.5,0r2

Default: 1

Flow Control list

Specifies flow-control type:

Default: None

box None, Hardware (RTS/CTS), or
Software (XONN, XOFF).
Log Clear — Does not copy Default: Clear
Communications | communications in log window.
Data to Log Checked — Copies
Window communications in log window.

IP Address text

Specifies IP address.

Must be in format

box 127.0.0.1:1000 or in format
host.domain.com:1000.
NOTE  For an Abatron remote connection, be sure to clear the checkboxes Use Target

Initialization File and Use Memory Configuration File, of the CF Debugger
Settings panel.

Freescale Remote Connections
Figure 5.12 shows the dialog box that appears for Freescale’s USB TAP remote

connection when the Connection Type list box is set to USB-TAP BDM. Figure 5.13

shows the dialog box that appears when the Connection Type list box is set to CCS
Remote Connection. Table 5.8 explains the elements of these dialog boxes.
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Figure 5.12 USB-TAP BDM

FREESCALE_USB-TAP Ef
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Figure 5.13 CCS Remote Connection
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Name: |FREESCALE_USE-TAP

DEbUggEfiICDIdFire CCS vl v Show in processes list

— Connection Type:
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Table 5.8 USB TAP Dialog Box Elements

Element

Purpose

Comments

Name text box

Identifies the remote connection.

For an existing
connection,
already has a
value.

Debugger list box

Identifies the debugger.

For an existing
connection,
already specifies
ColdFire CCS

Show in processes
list checkbox

Clear — Leaves the connection off the
official list.

Checked — Adds connection to the official
list (select View > Systems > List); also
adds connection to the pop-up list for
debugging certain kinds of file.

Default: Clear

Connection Type list Specifies USB-TAP BDM or CCS remote Default: USB-
box connection. Changing this value changes TAP BDM
the other elements of this dialog box, as in
Figure 5.12 and Figure 5.13.
Use Default Serial Each USB TAP device has a serial number | Default:
Number (in USB-TAP | (SN) burned into flash memory. The SN Checked.

BDM dialog box)

enables using multiple USB TAP devices
during a single debugging session.
Normally is checked.

USB TAP Serial
Number (hex) (in

If the “Use Default Serial Number”
checkbox is checked, enter the serial

Default: Grayed
out and blank.

USB-TAP BDM number here. Should be same SN burned

dialog box) into flash on the device.

CCS Timeout Timeout (in seconds) that CCS waits for a Default: 10
reply from the target before retrying.

Interface Clock Clock speed of the BDM or JTAG interface. | Default:

Frequency (in USB- 5.12MHz

TAP BDM dialog box)

Use Remote CCS (in | If checked, CCS uses Server IP Addressto | Default: Not

CCS Remote communicate with remote USB TAP (via checked

Connection dialog
box)

TCP-IP).
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Table 5.8 USB TAP Dialog Box Elements (continued)

Server IP Address (in

IP address of the CCS server or debug

Default: Grayed

dialog box)

CCS Remote interface device, to be used if Use Remote | out, with value:
Connection dialog CCS checkbox is checked. 127.0.0.1

box)

Specify CCS If checked, then enter the path and file Default: Not
Executable (in CCS name of the CCS executable you’d like to checked
Remote Connection use.

dialog box)

Multi-Core If checked, then enables multi-core Default: Not
Debugging (in CCS debugging support. checked. In
Remote Connection ColdFire

debugging, not
used.

JTAG Configuration
File (in CCS Remote
Connection dialog

If Multi-Core Debugging is checked, then
this field can be used to specify a desired
JTAG configuration file.

Default: Grayed
out. In ColdFire
debugging, not

box) used.

Reset Target on Determines whether target board (and Default:

Launch processor) is reset when debugging is Checked
initiated.

Enable Logging If checked, logs CCS communications to Default: Not
log window or file. checked

P&E Microsystems Remote Connections

Figure 5.14, Figure 5.15, Figure 5.16, Figure 5.17, Figure 5.18, and Figure 5.19 show the

configuration dialog boxes for PE Micro remote connections. Table 5.9 explains the
elements of these dialog boxes.
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Figure 5.14 P&E Micro Remote Connection (Parallel)

x
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Figure 5.15 P&E Micro Remote Connection (USB)
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Figure 5.16 P&E Micro Remote Connection (Lightning)

x
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Figure 5.17 P&E Micro Remote Connection (Cyclone Max Serial)

New Connection E3
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Figure 5.18 P&E Micro Remote Connection (Cyclone Max USB)

New Connection E
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Debuggel:IEoIdFile PEMicm vl [~ Show in processes list
— Connection Type:lec:Max se VI

USE Part |USED =
Speed |5

[~ Log Communications Data to Log Window

Figure 5.19 P&E Micro Remote Connection (Cyclone Max TCPIP)

New Connection E3
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Table 5.9 P&E Micro Dialog Box Elements

Element

Purpose

Comments

Name text box

Identifies the remote connection.

For an existing connection,
already has a value.

Debugger list

Identifies the debugger.

For an existing connection,

box already specifies ColdFire
P&E Micro
Show in Clear — Leaves the connection Default: Clear
processes list off the official list.
checkbox Checked — Adds connection to
the official list (select View >
Systems > List); also adds
connection to the pop-up list for
debugging certain kinds of file.
Connection Type | Specifies Parallel, USB, Changing this value changes
list box Lightning, Cyclone Max Serial, the subordinate elements of
Cyclone Max USB, or Cyclone the dialog box, as Figure 5.14,
Max TCPIP. Figure 5.15, Figure 5.16
Figure 5.17, Figure 5.18, and
Figure 5.19 show.
Log Clear — Does not copy Default: Clear
Communications | communications in log window.
Data to Log Checked — Copies
Window communications in log window.

Parallel Port list
box

Specifies the parallel port: LPT1,
LPT2, LPTS3, or LPTA4.

Default: LPT1.

Speed text box
(in parallel dialog
box)

Integer that modifies the data
stream transfer rate: 0 specifies
the fastest rate. The greater the
integer, the slower the rate.

For a parallel remote
connection there is no firm
mathematical relationship, so
you may need to experiment to
find the best transfer rate. In
case of problems, try value 25.

USB Port list box
(in USB dialog
box and Cyclone
Max USB dialog
box)

Specifies the USB port: USB 0,
USB 1, USB 2, or USB 4.

Default: USB 0
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Table 5.9 P&E Micro Dialog Box Elements (continued)

Speed text box
(in USB dialog
box)

Integer N that specifies the data
stream transfer rate per the
expression (1000000/(N+1))
hertz.

0 specifies 1000000 hertz, or 1
megahertz. 1 (the default)
specifies 0.5 megahertz. 31
specifies the slowest transfer
rate: 0.031 megahertz.

PCI card slot list
box

Specifies PCI slot that the board
uses.

Default: 1

Speed text box

Integer N that specifies the data

0 specifies 6600000 hertz, or

(in Lightning stream transfer rate per the 6.6 megahertz. 1 (the default)
dialog box) expression (33000000/(2*N+5)) specifies 4.7 megahertz. 31
hertz. specifies the slowest transfer
rate: 0.49 megahertz.
COM Port list Specifies the serial port: COM1, Default: COM1.

box (in Cyclone
Max Serial dialog
box)

COM2, COMS, ... or COM256.

IP Address text
box (in Cyclone
Max TCP/IP
dialog box)

Specifies IP address.

Must be in format
127.0.0.1:1000 or in format
host.domain.com:1000.

Speed text box
(in Cyclone Max
dialog boxes)

Integer N that specifies the data
stream transfer rate per the
expression (50000000/(2*N+5))
hertz.

0 specifies 5000000 hertz, or
5.0 megahertz. 5 (the default)
specifies 3.33 megahertz. 31

specifies the slowest transfer
rate: 0.75 megahertz.

NOTE

For a P&E Micro remote connection, be sure to check the checkboxes Use

Target Initialization File and Use Memory Configuration File, of the CF
Debugger Settings panel.

ISS Remote Connection

NOTE

Special-Edition software does not support the ISS. To use the ISS, you must

have Standard- or Professional-Edition software.

Figure 5.20 shows the configuration dialog box for ColdFire Instruction Set Simulator
(ISS) remote connections. Table 5.10 explains the elements of this dialog box.
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Figure 5.20 ISS Remote Connection
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NOTE  To use the ISS for V2 and V4e cores, create a CCS remote connection.
Alternatively, use the default CCS - SIM connection from the Remote
Connection panel list.

Table 5.10 ISS Dialog-Box Elements

Elements Purpose Comments
Name text box Identifies the remote connection. For an existing
connection, already has
a value.
Debugger list Identifies the debugger. For an existing
box connection, already
specifies ColdFire CCS
Show in Clear — Leaves the connection off the Default: Clear
processes list official list.
checkbox Checked — Adds connection to the
official list (select View > Systems >
List); also adds connection to the pop-
up list for debugging certain kinds of file.
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Table 5.10 ISS Dialog-Box Elements (continued)

Elements Purpose Comments
Connection Specifies CCS Remote Connection Changing this value
Type list box changes other elements
of the dialog box.
Use Remote Clear — Launches the CCS locally. ISS must be running and
CCS checkbox Checked — Starts debug code on a connected_ to a remote
o target device.

remote target; activates Server IP

Address text box.
Server IP Specifies IP address of the remote Available only if you
Address text machine, in format 127.0.0.1:1000 or check the Use
box host.domain.com:1000.

Remote CCS checkbox.

Port # text box

Specifies the port number the CCS uses

Use only 40969 — the
number of the port pre-
wired for the simulator.

Specify CCS
Executable
checkbox

Clear — Uses the default CCS
executable file.

Checked — Lets you specify a different
CCS executable file, activating the text
box and Choose button. To do so, click
the Choose button, then use the
subordinate dialog box to select the
executable file. Clicking OK puts the
pathname in the text box.

Does not pertain to the
simulator.

Multi-Core
Debugging
checkbox

Clear — Does not debug code on a
multicore target.

Checked — Lets you specify the JTAG
chain for debugging on a multicore
target, activating the text box and
Choose button. To do so, click the
Choose button, then use the
subordinate dialog box to select the
executable file. Clicking OK puts the
pathname in the text box.

Does not apply to the
simulator.

CCS Timeout
text box

Specifies the number of seconds the
CCS should wait for a connection to go
through, before trying the connection
again.
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BDM Debugging

This section show two examples of connections for Background Debugging Mode (BDM)
debugging of a ColdFire target board.

Connecting a P&E Parallel Connector

Figure 5.21 depicts connections for a P&E Parallel Remote Connection.

Figure 5.21 P&E Parallel Remote Connector Setup

P&E Parallel Connector

BDM connector ?\/

} Parallel cable
to PC parallel port

Target board

Follow these steps:

1. Plug the P&E Parallel Connector onto the target-board BDM connector.
2. Connect the parallel cable to the P&E Parallel Connector.

3. Connect the other end of the parallel cable to a parallel port of your PC.
4

. This completes P&E Parallel connection. The P&E Parallel Remote Connection
automatically installs a default set of drivers and interface dlls on your PC.

NOTE  You must have the correct P&E Parallel Connector for your target. If
necessary, contact P&E Microsystems for assistance.
The Windows drivers for P&E Microsystems BDM cables are available as well
in subdirectory bin\Plugins\Support\ColdFire\pemicro of your
CodeWarrior installation directory.

Connecting an Abatron BDI Device

Figure 5.22 depicts connections for an Abatron BDI device.
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Figure 5.22 Abatron BDI Connections

JTAG connector Power connector

(on end of BDI)

TCP/JP connector

RCD cable

Power cable

To target-board .
JTAG connector Serial connector
Serial cable
to PC serial port

Follow these steps:
1. Connect the BDI device to your computer.

a. Serial connection: Connect a serial cable between the BDI serial connector and a
serial port of the PC, as Figure 5.22 shows.

b. TCP/IP connection: Connect a TCP/IP cable between the BDI TCP/IP connector
and an appropriate port of your PC.

2. Connect the appropriate RCD cable between the BDI JTAG connector and the JTAG
connector of your target board. (The board JTAG connector is a 26-pin Berg-type
connector.)

NOTE  Certain target boards, such as the MCF5485, MCF5475, MCF5235, and
MCF5271, require a different RCD cable than do other ColdFire boards. To
make sure that your cable is correct, see the Abatron reference manual or visit
http://www.abatron.ch.

3. Connect the power cable between the BDI power connector and a 5-volt, 1-ampere
power supply, per the guidance of the Abatron user manual.

4. This completes cable connections.

NOTE  Before using an Abatron remote connection, you must
1. Make sure that you have the correct drivers and configuration utility for your
target board.
2. Use Abatron software to configure the BDI device, per the guidance of the
Abatron user manual.
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Before you use the BDI for ROM/Flash debugging, you must check the Use
Breakpoint Logic checkbox of the BDI Working Mode dialog box.

Debugging ELF Files without Projects

The CodeWarrior debugger can debug an ELF file that you created in a different
environment. But before you begin, you must update IDE preferences and customize the
default XML project file. (The CodeWarrior IDE uses the XML file to create a project
with the same target settings for any ELF file that you open to debug.)

Updating IDE Preferences

Follow these steps:

1. From the main menu bar, select Edit > Preferences. The IDE Preferences window
appears.

2. From the IDE Preferences Panels pane, select Build Settings. The Build Settings
panel (Figure 5.23) moves to the front of the window.
Figure 5.23 Build Settings Panel
§ Build Settings

— Settingsz
¥ Save open files before build
[ Show message after building up-to-date project

Compiler thread stack [kb]: 325

Build before running: [FEMS

—I~ Use Local Project Data Storage

|{Compiler}LocaI_Data_Storage Choose,.. I

|Jzed when the project data folder cannot be created on read-only volumes.

3. Make sure that the Build before running list box specifies Never.

NOTE  Selecting Never prevents the IDE from building the newly created project,
which is useful if you prefer to use a different compiler.

4. Select Edit > Preferences > Global Settings. The Global Settings panel (Figure
5.24) moves to the front of the window.
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Figure 5.24 Global Settings Panel

§ Global Settings

— v Cache Edited Files Between Debug Sessions

I'I daps.

taintain files in cache for

Purge Cache I

— Other Settingz
[ Confirm ireealid file modification dates when debugging

[ Automatically launch applications when opening a 57 file
¥ Confirm "Kill Process" when closing or quitting the application
¥ Select thread window when stopping task

¥ Do not step into runtime support code

[ Auto target braries

5. Make sure that the Cache Edited Files Between Debug Sessions checkbox is clear.

6. Close the IDE Preferences window.

7. This completes updating IDE preference settings; you are ready to customize the

default XML project file.

Customizing the Default XML Project File

CodeWarrior software creates a new CodeWarrior project for any ELF file that you open
to debug. To create the new project, the software uses the target settings of the default

XML project file:

bin\plugins\support\CF_Default_Project.xml

For different target settings, you must customize this default XML file. Follow these steps:

1. Import the default XML project file.

Select File > Import Project — a file-select dialog box appears.

a.
b. Navigate to subdirectory bin\plugins\support.

o

Select file CF_Default_Project.xml.

a

Click OK — a new project window appears for file
CF_Default_Project.xml.

2. Change target settings of the new project.

Select Edit > Target Settings — the Target Settings window appears.

b. From the Target Settings Panels pane, select any panel — that panel moves to the

front of the window.

c. Review/update panel settings.
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d.

Repeat substeps b and c for all other appropriate panels.

e. When all settings are correct, click OK — the Target Settings window closes; the

system updates project settings.

3. Close the project window.

4. Export the modified target settings.

a
b.

e o

Select File > Export Project — a file-select dialog box appears.

Navigate to subdirectory bin\plugins\support.

Select the file you just modified: CF_Default_Project.xml.

Click OK — the system saves your modified file CF_Default_Project.xml

over the old file.

5. This completes XML-file customization — the new CF_Default_Project.xml

file includes your target-settings changes; you are ready to debug an ELF file.

Debugging an ELF File

Once you have updated IDE preferences and customized the default XML file, you are
ready to debug an ELF file (that includes symbolics information). Follow these steps:

1. Confirm that a remote connection exists for the ColdFire target.

2. Open Windows Explorer.
3. Navigate to the ELF file.
4

. Drag the ELF file to the IDE main window — the IDE uses the default XML file to

create a new project, opening a new project window.

NOTE

5. Select Project > Debug — the IDE starts the debugger; the debugger window

As ELF-file DWARF information does not include full pathnames for

assembly (. s) files; the IDE cannot find these files when it creates the project.

But when you debug the project, the IDE does find the assembly files that

reside in a directory that is a project access path. If any assembly files still lack
full pathnames, you can add their directory to the project manually, so that the

IDE finds the directory whenever you open the project.

appears.

6. Begin debugging.

Additional ELF-Debugging Considerations

Any of these points may make your debugging more efficient:
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Once the IDE creates a .mcp project for your ELF file, you can open that project
instead of dropping your ELF file onto the IDE.

To delete an old access path that no longer applies to the ELF file, use either of two
methods:

— Use the Access Path target settings panel to remove the access path from the
project manually.

— Delete the existing project for the ELF file, then drag the ELF file to the IDE to
recreate a project.

To have the project include only the current files, you must manually delete project
files that no longer apply to the ELF.

To recreate a project from an ELF file:
— If the project is open, close it.
— Delete the project (.mcp) file.

— Drag the ELF file to the IDE — the IDE opens a new project, based on the ELF
file.

Special Debugger Features

Table 5.11 ColdFire Debug Menu

This section explains debugger features that are unique to ColdFire-platform targets.

ColdFire Menu

To see the unique Coldfire debugger menu, select Debug > ColdFire. Table 5.11 lists its

selections.

Selection

Explanation

Reset Target

Sends a reset signal to the target processor. (Not available
unless the target processor supports this signal.)

Save Memory

Saves target-board data to disk, as a binary image file.

Load Memory

Writes previously saved, binary-file data to target-board
memory.

Fill Memory

Fills a specified area of memory with a specified value.

Save Registers

Saves contents of specified register to a text fie.
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Table 5.11 ColdFire Debug Menu (continued)

Selection Explanation

Restore Registers Writes previously saved register contents back to the
registers.

Watchpoint Type Specifies the type:
Read — A read from the specified memory address stops
execution.

Write — A write to the specified memory address stops
execution.

Read/Write — Either a read from or write to the specified
memory address stops execution.

(Not available unless the target processor and debug
connection support watchpoints.)

Working with Target Hardware

To have the IDE work with target hardware, use Debug-menu selections Connect and
Attach.

Connect

This selection tells the IDE to read the contents of target-board registers and memory;
these contents help you determine the state of the processor and target board. You can use
this selection in combination with the Load/Save Memory and Fill Memory selections of
the ColdFire menu to create a memory dump, load memory contents, or initialize memory
with specific patterns of data.

You can have the IDE connect to a target board that uses ColdFire Abatron or ColdFire
P&E Micro protocols.

The Connect selection works with a remote connection that you define in a project:

1. Bring forward the project you want to use. (The project must have at least one remote
connection defined for the target hardware.)

2. Select Debug > Connect — a Thread window appears, showing where the IDE
stops program execution. The debugger configuration file is executed.

3. Use the Thread window, with other IDE windows, to see register views and memory
contents.
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Using the Simple Profiler

NOTE

The fol

For a detailed explanation of how to instrument your code for profiling and
how to interpret the results, see the “Profiler” chapter in the IDE 5.7 User’s
Guide.

lowing steps for enabling and using the profiling tool make reference to ColdFire-

specific features that may not be mentioned in the IDE User’s Guide:

1. Specify profiling, in one of these ways:

2. Ify

In the ColdFire Processor panel, check the Generate code for profiling checkbox.

Use the #pragma profile on directive before the function definition and use
the #pragma profile off directive after the function definition.

Use the -profile option or the #pragma directives with the command-line
compiler.

ou use the #pragma directives, add the profiler libraries to your project. (These

libraries are in subdirectory \E68K_Support\Profiler\Lib\ of your
CodeWarrior installation directory.)

3. Inyour source code, use the #include directive to include header file
Profiler.h. (This file is in subdirectory
\E68K_Support\Profiler\include\ of your CodeWarrior installation
directory.)

4. Ifn
are

a.
b.

/& 0

c.

ecessary, instrument your code with the following function calls. These functions
documented in the “Profiler” chapter of the IDE User’s Guide:

ProfilerInit — initializes the profiler.
ProfilerClear — removes existing profiling data.
ProfilerSetStatus — turns profiling on (1) or off (0).

ProfilerDump ("filename") — dumps the profile data to a profiler window
or to the specified file.

ProfilerTerm— exits the profiler.

The profiler libraries use the external function getTime to measure the actual execution

time.

NOTE

For a list of ColdFire platforms supported by the profiler, see the subdirectory
\E68K_support\Profiler\Support\ of your CodeWarrior
installation directory. The files in that directory also contain examples using
the getTime() function.
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This chapter explains how to use the Instruction Set Simulator (ISS). Using the ISS with
the CodeWarrior™ debugger, you can debug code for a ColdFire target.

Additionally, if you run the ISS on your host computer, you can share target-board access
with remote users of the CodeWarrior debugger.

In the same way, you can access the target board of any remote computer that is running
the ISS, provided that you know the IP address and ISS port number of that remote
computer.

NOTE  Special-Edition software does not support the ISS; to use the ISS, you must
have Standard- or Professional-Edition software.

Do not move the ISS folders or files from its location in subdirectory
\Bin\Plugins\Support\Sim, of your CodeWarrior installation
directory. You can start the ISS only from the CodeWarrior debugger.

This chapter consists of these sections:
» Features
* Using the Simulator
* ISS Configuration Commands

* Sample Configuration File
¢ ISS Limitations

Features

Your CodeWarrior software supports the Instruction Set Simulator (ISS) for V2 and V4e
cores.

ColdFire V2

For V2 cores the ISS features are:

* Instruction set — modeling only of the original ColdFire v2 instruction set, without
ISA+ support of the 5282 processor.
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Features
MAC — modeling of the MAC without the EMAC of the 5282 processor. (This
affects register accesses.)
Cache — modeling of the original ColdFire v2 direct-mapped instruction cache,
without modeling of the 5282 instruction and data cache.
Format exceptions — not implemented.
IPSBAR Functionality (5282 Peripherals) — modeling of the IPSBAR register and
Synchronous DRAM Controller (SDRAMC) module. (No modeling of other 5282
peripherals or related behavior.)
IPSBAR register fields — all implemented.
SDRAMC registers — five present:
- DCR
- DACRO
— DACRI
— DMRO
- DMRI
DCR — this model includes reads from and writes to this register, but ignores all
internal fields of this register.
DACRx — this model includes reads from and writes to these fields. (The SDRAMC
model covers functionality only of DACRX register fields BA and CBM, ignoring
other fields.)
DMRx — this model includes reads from and writes to these fields. (The SDRAMC
model covers functionality only of DMRx register fields BAM and V, ignoring other
fields.)
KRAM, KROM — support as much as 512 kilobytes of memory.
Memory wait states — supported.
A-line exceptions — not generated, as this model includes MAC.
NOTE  The V2 ISS has pipeline delays that can lead to debugger defects.
ColdFire V4e
For V4e cores the ISS features are:
 Instruction set — modeling for all instructions.
* EMAC — modeling of the EMAC.
¢ FPU — not supported.
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Cache — modeling of the ColdFire V4e four-way set-associative instruction and data
caches. (Caches always are physically tagged and physically addressed.)

MMU model — partially supported.

WDEBUG instruction — not supported, as the model does not support the
WDEBUG module.

WDDATA instruction — not supported, as the model does not support the WDDATA
module.

PULSE instruction — not supported, as the model does not support the PULSE
debug module.

IPSBAR Functionality (5282 Peripherals) — modeling of the IPSBAR register. (No
modeling of other peripherals or related behavior.)

A-line exceptions — not generated, as this model includes EMAC.
F-line exceptions — not generated, as this model includes an FPU.
Clock multiplier — not supported.

Memory wait states — not supported.

NOTE  Pipeline delay can lead to appearance problems in the debugger variable

viewer.

Using the Simulator

When you use a local ISS connection for debugging, the IDE starts the ISS automatically;
the ISS icon appears on the taskbar.

Right-click the icon to access the ISS pop-up menu. Its selection are:

Configure — opens the ISS configuration options dialog box

Show console — displays the ISS console window. (Another way to open this
console window is double-clicking the ISS icon.)

Hide console — hides the ISS console window
About CCSSIM2 — displays version information
Quit CCS — stops the ISS.

Console Window

Use the ISS console window to view and change server connection options. You may type
commands at the command line, or select them from the menu bar.
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NOTE Do not use the console window to modify settings during a debug session. This
would affect the debug state.

Viewing ISS Registers

To view the ISS registers, select View > Registers — the Registers window (Figure 6.1)
appears.

Figure 6.1 Register Window: ISS Register Values

i

R Register [ Value |
- ISS Registers [

b INSTCNT 8689 |=]

‘o CYCLCNT 22986 4

You may edit the ISS register values that this window shows.
¢ INSTCNT (Instruction Count) is the number of instructions executed in a debug

session.

* CYCLCNT (Cycle Count) is the number of elapsed clock cycles in a debug session.

NOTE  These registers are unique to ISS projects; other projects do not have these
registers.

ISS Configuration Commands

The ISS reads configuration information from configuration files ColdFire2.cfg (V2
core) and ColdFired.cfg (V4e core). Both files are in subdirectory
\Bin\Plugins\Support\Sim\ccssim2\bin of your CodeWarrior installation
directory.

NOTE Do not change the location of the configuration files, or the ISS may not work
properly.

If you cannot use the ISS to start a debug session, you probably must reduce
the memory that file ColdFire2.cfgor ColdFired.cfg defines. And
for an MCF5282 or other processor core that had IPSBAR, you must use the
ipsbar command to configure the settings.

The configuration files consist of text commands, each on a single line:
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* Some argument values are numerical.
* Possible boolean argument values are true (or yes) and false (or no).
¢ Comment lines must start with the # character.
The rest of this section consists of explanations for the ISS configuration commands:
¢ bus_dump
e cache size
* ipsbar
e kram_size
e krom_size
e krom_valid
* mbar
e mbus_multiplier
* memo

e sdram

bus_dump

Controls dumping bus signals to the processor . bus_dump file. bus_dump switch

bus_dump switch

Parameter
switch

Boolean value yes (or true) or no (or false).

Remarks
If environment variable CF_REG_DUMP is set, a yes or true switch value for
this command also dumps the CPU register values to the
processor.reg_dump file.

Example

bus_dump true
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cache_size

Configures the cache size.

cache_size size_parameter

Parameter
size_parameter

Default value 0 (off), or another code number for the size, per Table 6.1.

Table 6.1 Cache Size Parameter Conversion

size_paramet Kilobytes size_paramet Kilobytes

er er

0 0 4 4

1 0.5 5 8

2 1 6 16

3 2 7 32
Example

cache_size 7

ipsbar

Provides beginning address and offset, enabling V4-core IPSBAR registers. (The V4
counterpart command is mbar.)

ipsbar switch

Parameter
switch

Boolean value yes (or true) or no (or false).

Example

ipsbar true
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kram_size

Configures the KRAM size.

kram_size size_parameter

Parameter
size_parameter

Code number for the size, per Table 6.2.

Table 6.2 kram Size Parameter Conversion

size_paramet Kilobytes size_paramet Kilobytes

er er

0 0 6 16

1 0.5 7 32

2 1 8 64

3 2 9 128

4 4 10 256

5 8 11 512
Example

kram_size 7

krom_size

Configures the KROM size.

krom_size size_parameter

Parameter
size_parameter

Code number for the size, per Table 6.3.
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Table 6.3 krom Size Parameter Conversion

size_paramet Kilobytes size_paramet Kilobytes

er er

0 0 6 16

1 0.5 7 32

2 1 8 64

3 2 9 128

4 4 10 256

5 8 11 512
Example

krom_size 11

krom_valid

Controls KROM mapping to address $0 at boot-up.

krom_valid switch

Parameter
switch

Boolean value yes (or true) or no (or false).

Example

krom_valid true

mbar

Provides beginning address and offset, enabling V2-core MBAR registers. (The V4
counterpart command is ipsbar.)

mbar switch
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Parameter
switch

Boolean value yes (or true) or no (or false).

Example

mbar true

mbus_multiplier

For a V2-core processor, multiplies the core clock speed.

mbus_multiplier value

Parameter
value

Any integer between 1 and 10.

Example

mbus_multiplier 10

memory

Configures sections of external memory.

memory start end wait_states line_wait_states

Parameters
start

Starting address of the contiguous section of memory.
end

Ending address of the contiguous section of memory.
walt_states

Number of wait states inserted for normal access (for V2 ISS only).
line_wait_states

Number of wait states inserted for line access (for V2 ISS only).
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Remarks

There may be any number of MBUS memories, each with different wait states
settings.

You must provide wait_states and 1ine_wait_states values fora V2
ISS, but you should not provide these values for a V4 ISS.
Examples
memory 0x00000000 OxOfffffff 0 O
memory 0x200000000 0x3000ffff 0 O

sdram

Configures SDRAM.

sdram bank_bits num_bytes wait_states line_wait_states

Parameters
bank_bits

Number of bank bits used (only two banks are allowed).
num_bytes

Number of bytes allocated.
walt_states

Number of wait states inserted for normal access (for V2 ISS only).
line_wait_states

Number of wait states inserted for line access (for V2 ISS only).

Example
sdram 2 0x8000 0 O

Sample Configuration File

Listing 6.1 shows configuration file ColdFire2.cfg.

Listing 6.1 ColdFire2.cfg File Example

#Example Configuration File
memory 0x0000 O0x7fff 0 O
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kram_size 8
bus_dump on
sdram 2 0x8000 0 O
ipsbar true

ISS Limitations

These limitations apply to the ISS:

* You cannot set hardware breakpoints, because debugging is not happening on an
actual hardware board.

* You cannot set watchpoints in source code.

* You cannot use the Attach feature while you use the ISS.

¢ The Run Without Debugger button h does not work, if you use the ISS to run
your application.
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This chapter explains the CodeWarrior IDE hardware tools, which you can use for board
bring-up, test, and analysis. These tools are not used with CCS-SIM or other simulators.

This chapter consists of these sections:

¢ Flash Programmer
* Hardware Diagnostics

Flash Programmer

Use the CodeWarrior flash programmer to program target-board flash memory with code
from any CodeWarrior IDE project, or with code from any individual executable files.

The flash programmer runs as a CodeWarrior plug-in, using the CodeWarrior debugger
protocol API to communicate with the target boards. The CodeWarrior flash programmer
lets you use the same IDE to program the flash of any of the embedded target boards.

NOTE  For Special-Edition software, the CodeWarrior flash programmer is limited to
128 kilobytes. There is no such limitation for Standard-Edition or Professional-
Edition software.
Each software edition also comes with an optional ColdFire flash programmer,
available in subdirectory
\bin\Pugins\Support\Flash_ Programmer of the CodeWarrior
installation directory.

Follow these steps:
1. Make sure to build the application you want to program into flash memory.

2. From the IDE main menu bar, select Tools > Flash Programmer — the Flash
Programmer window (Figure 7.1) appears.
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Flash Programmer

Figure 7.1 Flash Programmer Window: Target Configuration Panel

{ B Flash Programmer =101 x]

B Flash Programmer IE Target Configuration

- Tarnget Configuration
i+ Flash Configuration Default Project: kyProjmep

i Checksum —1 Use Custom Settings

Program £ Werify

Erase 7 Blank Chack Default Target: M5213EWE Console Debug

Target Processar: IGeneric ‘I Cannection: |ABATROMN_SERIAL 'I
e Target Intialization
IC:\F’rogram Files'Metrowerks T for ColdFire B.08PowerPC_EABI_S Browse,..

— Target Rk Memary Buffer Option:
Target kemory Buffer Address: DKIDDDDDDDD V¥ Enable Logging
Target Memory Buffer Size: DHIUUDDBUDD I~ ey Target Memory ‘writes
Show Log | Load Settings... | Save Settings... |

0k I Cancel |

3. If the Target Configuration panel is not visible, select if from the list at the left — the
panel moves to the front of the Flash Programmer window.

4. Verify Target Configuration settings.

If the Default Project field specifies your project, skip ahead to substep c.

Otherwise, from the main menu bar, select Project > Set as default project to
specify your project.

If the Default Target field specifies the correct Flash target, skip ahead to substep e.

Otherwise, from the main menu bar, select Project > Set as default target to
specify the correct Flash target.

Make sure that the Use Custom Settings checkbox is clear.
Click the Load Settings button. A file browser will appear.

Browse to bin\Pugins\Support\Flash_Programmer\ColdFire and
select the appropriate xml file, then press Open — the system updates other
settings for the default project and target.

5. Configure the flash device.
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a. From the pane list at the left of the Flash Programmer window, select Flash
Configuration — the Flash Configuration panel moves to the front of the window,
as Figure 7.2 shows.

Figure 7.2 Flash Programmer Window: Flash Device Configuration Panel

S
8 Flash Programmer | Imh Device Configuration
Target Configuration
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; IFFEDDDUD

Frogiam / Veriy Flash Memory Baze Address: Ox
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INZ8FO0ESC FFE10000 FFE1FFFF
IN28FO1 -t T FFE20000 FFEZ2FFFF
INZBFO1653 1k FFE30000 FFE3FFFF
IN28F01655 TM=16x2 FFE40000 FFE4FFFF
IN28F01 BSA FFES0000 FFESFFFF
INZBFOMBSC FFEE0000 FFEEFFFF
IN28FO1 65 FFE70000 FFEFFFFF
INZEF12813 FFEBO000 FFERFFFF
IN2gF128K18 - FFE30000 FFESFFFF
IN28F128K3 FFEADDOD FFEAFFFF
IN28F160B36 FFEBO000 FFEBFFFF
IN28F160B3T FFECO000 FFECFFFF
IN28F160C3E FFEDOO00 FFEDFFFF

FFEEDOOD FFEEFFFF
IN28F1G0F38 FFEFO000 FFEFFFFF
IN28F1BOF3T LI FFFO0000 FFFOFFFF LI
Show Lag | Load Settings... | Save Settings... |
0k I Cancel |

b. Make sure that the Device list box specifies your external flash device, or the on-
chip flash of your ColdFire-derivative processor.

c. Make sure that the Flash Memory Base Address text box specifies the appropriate
base address.

d. The Organization and Sector Address Map boxes display appropriate additional
information.

6. Erase the destination flash-memory sectors.

ColdFire Architectures v6.3 - Targeting Manual 105



Using Hardware Tools
Flash Programmer

a. From the pane list at the left of the Flash Programmer window, select Erase/
Blank Check — the Erase/Blank Check panel moves to the front of the window,
as Figure 7.3 shows.

Figure 7.3 Flash Programmer Window: Erase/Blank Check Flash Panel
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b. In the panel’s list box, select the sectors you want to erase. (To select them all,
check the All Sectors checkbox.)

Click the Erase button — the flash programmer erases the sectors.

d. (Optional) To confirm erasure, select the same sectors, then click the Blank Check
button — a message reports the status of the sectors.

7. Flash your application.
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a. From the pane list at the left of the Flash Programmer window, select Program/
Verify — the Program/Verify Flash panel moves to the front of the window, as

Figure 7.4 shows.

Figure 7.4 Flash Programmer Window: Program/Verify Flash Panel
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b. Make sure that the Use Selected File checkbox is clear.

c. Click the Program button — the flash programmer programs your application into
the target sectors of flash memory.

d. (Optional) To confirm programming, click the Verify button — the flash
programmer compares the data now in flash sectors to the image file on disk.

8. (Optional) For an additional test of programmed flash sectors, run a checksum.
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a. From the pane list at the left of the Flash Programmer window, select Checksum
— the Checksum panel moves to the front of the window, as Figure 7.5 shows.

Figure 7.5 Flash Programmer Window: Checksum Panel
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b. In the Compute Checksum Over area, select the appropriate option button: File on
Target, File on Host, Memory Range on Target, or Entire Flash.

c. If this selection activates the Address Range text boxes, enter the appropriate Start
and Size values.

d. Click the Calculate Checksum button — the flash programmer runs the checksum
calculation; a message tells you the result.

9. This completes flash programming.

Hardware Diagnostics

Use the CodeWarrior hardware diagnostics tool to obtain several kinds of information
about the target board. The Hardware Diagnostics feature is not supported by the ISS.

Select Tools > Hardware Diagnostics from the IDE main menu bar — the Hardware
Diagnostics window (Figure 7.6) appears.
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Figure 7.6 Hardware Diagnostics window: Configuration Panel
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Figure 7.6 shows the Configuration panel. Click any name in the list pane to bring the
corresponding panel to the front of the window:

* Memory Read/Write Test — which Figure 7.7 shows.
* Scope Loop Test — which Figure 7.8 shows.
* Memory Tests — which Figure 7.9 shows.

NOTE  InFigure 7.7, Figure 7.8, and Figure 7.9, be sure to use addresses which are in
the memory map for your hardware configuration (which are defined through
the configuration file).
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Figure 7.7 Hardware Diagnostics window: Memory Read/Write Test Panel
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Figure 7.8 Hardware Diagnostics window: Scope Loop Test Panel
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Figure 7.9 Hardware Diagnostics window: Memory Tests Panel
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The Hardware Diagnostics window lists global options for the hardware diagnostic tools;
these preferences apply to every open project file. For more information about each
hardware-diagnostics panel, see the IDE User’s Guide .
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8

Using Debug Initialization
Files

This appendix explains background debugging mode (BDM) support for the ColdFire
reference boards. BDM controls the processor, accessing both memory and I/O devices
via a simple serial, wiggler interface. BDM can be very useful during initial debugging of
control system hardware and software; it also can simplify production-line testing and
end-product configuration.

Specifically, this appendix explains how to use debug initialization files with the P&E
Micro wiggler. Debug initialization files contain commands that initialize the target board
to write the program to memory, once the debugger starts the program.

Each time you start the debugger, and each time you select Debug > Reset Target, the
system processes a debug initialization file. Such a file perform such functions as

initializing registers and memory in targets that do not yet have initialization code in
ROM.

This appendix consists of these sections:
¢ Common File Uses
* Command Syntax
¢ Command Reference

You specify whether to use a debug initialization file — and which to use — via the
ColdFire Target Settings panel.

Common File Uses

The most common use for debug initialization files is configuring the essential set of
memory-control registers, so that downloads and other memory operations are possible.
This is appropriate if your target system or evaluation board does not yet have
initialization code in target ROM. It also can be an appropriate way to override an existing
initialization after a reset.

To create this section of the debug initialization file, you mirror the values that the
processor chip-select, pin-assignment, and other memory control registers should have
after execution of initialization code. However, the set of registers that need initialization
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varies by processor. For details, see your processor data book, as well as the sample files
in the CodeWarrior subdirectory \E68K_Tools\Initialization_Files.

Other uses and guidance items are:

* Sample files are specific to processor, and, in most cases, evaluation board. Use the
sample templates for your own board.

* Use a debug initialization file only to initialize memory setup. Trying to use such a
file for additional initialization, such as for on-board peripherals or setup ports,
would prevent these other initializations during normal execution. As the program
does not use BDM in normal execution, it would not initialize such peripherals, so
the program could fail to execute properly.

¢ Put non-memory and non-exception-setup initialization instructions in the
init_hardware function of processor startup code instead of in a debug
initialization file. Another valid place for such instructions is your own start routine.
These methods take care of initialization.

¢ Once debugging is done, your startup code must initialize the memory management
unit, setting up the memory appropriately for non-debugger program execution.

» Listing 8.1 is a sample BDM initialization file for the MCF5272C3 board.

Listing 8.1 Sample BDM Initialization file

; Set VBR to start of future SDRAM

; VBR is an absolute CPU register

; SDRAM is at 0x00000000+0x0400000
writecontrolreg 0x0801 0x00000000

; Set MBAR to 0x10000001

; MBAR is an absolute CPU register, so if
; you move MBAR, you must change all subsequent
; writes to MBAR-relative locations
writecontrolreg 0x0COF 0x10000001

; Set SRAMBAR to 0x20000001

; SRAMBAR is an absolute CPU register, the
; location of chip internal 4k of SRAM
writecontrolreg 0x0C04 0x20000001

; Set ACRO to 0x00000000

writecontrolreg 0x04 0x00000000

; Set ACR1 to 0x00000000
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writecontrolreg 0x05 0x00000000
; 2MB FLASH on CS0 at OxFFE00000

writemem.l 0x10000040 OxXFFE00201
writemem.l 0x10000044 OxFFE00014

; CS7 4M byte SDRAM
; Unlike 5307 and 5407 Cadre 3 boards,
; the 5272 uses CS7 to access SDRAM

writemem.l 0x10000078 0x00000701
writemem.1l 0x1000007C OxFFC0007C

; Set SDRAM timing and control registers
; SDCTR then SDCCR

writemem.1l 0x10000184 0x0000F539
writemem.1l 0x10000180 0x00004211

; Wait a bit

delay 600

writemem.l 0x10000000 OxDEADBEEF
; Wait a bit more

delay 600

Command Syntax

The syntax rules for commands in a debug initialization file are:
» The system ignores space characters and tabs.
* The system ignores character case in commands.
* Numbers may be in hexadecimal, decimal, or octal format:

— Hexadecimal values must start with 0x, as in 0x00002222, 0xA, or
0xCAfeBeaD.

— Decimal values must start with a numeral 1 through 9, asin 7, 12, 526, or
823643.

— Octal values must start with a zero, asin 0123, or 0456.

ColdFire Architectures v6.3 - Targeting Manual 115



Using Debug Initialization Files
Command Reference

¢ Start comments with a colon (;), or pound sign (#). Comments end at the end of the
line.

Command Reference

This section explains the commands valid for debug initialization files:
« Delay
¢ ResetHalt
* ResetRun
* Stop
¢ writeaddressreg
* writecontrolreg
¢ writedatareg

e writemem.b
e writemem.l

e writemem.w

NOTE  Old data initialization files that worked with a Macraigor interface may not
work with a P&E interface because command writereg SPRnn changed to
writecontrolreg OxNNNN. Please update files accordingly.

Delay

Delays execution of the debug initialization file for the specified time.

Delay <time>

Parameter
time

Number of milliseconds to delay.

Example

This example creates a half-second pause in execution of the debug initialization
file:

Delay 500
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ResetHalt

Resets the target, putting the target in debug state.
ResetHalt

ResetRun

Resets the target, letting the target execute from memory.

ResetRun

Stop
Stops program execution, putting the target in a debug state.
Stop

writeaddressreg

Writes the specified value to the specified address register.

writeaddressreg <registerNumber> <value>

Parameters
registerNumber

Any integer, 0 through 7, representing address register AQ through A7.
value

Any appropriate register value.

Example
This example writes hexadecimal £ £ to register A4:

writeaddressreg 4 Oxff
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writecontrolreg

Writes the specified value to the address of a control register.
writecontrolreg <address> <value>

address is the address of the control register.

Parameters
address

Address of any control register.
value

Any appropriate value.

Example
This example writes hexadecimal c0 £ to control-register address 20000001:

writecontrolreg 0xcOf 0x20000001

writedatareg

Writes the specified value to the specified data register.

writedatareg <registerNumber> <value>

Parameters
registerNumber

Any integer, 0 through 7, representing data register DO through D7.
value

Any appropriate register value.

Example
This example writes hexadecimal £ £ to register D3:

writedatareg 3 Oxff
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writemem.b

Writes the specified byte value to the specified address in memory.

writemem.b <address> <value>

Parameters
address

One-byte memory address.
value

Any one-byte value.

Example
This example writes decimal 255 to memory decimal address 2345:

writemem.b 2345 255

writemem.l

Writes the specified longword value to the specified address in memory.

writemem.l <address> <value>

Parameters
address

Four-byte memory address.
value

Any four-byte value.

Example

This example writes hexadecimal 00112233 to memory hexadecimal address
00010000:

writemem.l 0x00010000 0x00112233
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writemem.w

Writes the specified word value to the specified address in memory.

writemem.w <address> <value>

Parameters
address

Two-byte memory address.
value

Any two-byte value.

Example

This example writes hexadecimal 12ac to memory hexadecimal address
00010001:

writemem.w 0x00010001 Oxl2ac
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In your overall memory map, there can be gaps or holes between physical memory
devices. If the debugger tries a read or write to an address in such a hole, the system would
issue an error message, and debugging might not even be possible.

To prevent such developments, use a memory configuration file (MCF). An MCF
identifies valid memory address ranges to the debugger, and even specifies valid access

types.

NOTE  The memory configuration file for your project should be updated to the latest
memory configuration file for your hardware configuration. Up-to-date
memory files can be found in
\E68K_Support\Initialization_Files.

A sample memory configuration file is
\E68K_Support\Initialization_Files\MCF5485EVB.mem of the
CodeWarrior installation directory.

This appendix consists of these sections:

* Command Syntax
* Command Explanations

Command Syntax

The syntax rules for commands in a memory configuration file are:
* The system ignores space characters and tabs.
* The system ignores character case in commands.
* Numbers may be in hexadecimal, decimal, or octal format:

— Hexadecimal values must start with 0x, as in 0x00002222, 0xA, or
0xCAfeBeaD.

— Decimal values must start with a numeral 1 through 9, asin 7, 12, 526, or
823643.

— Octal values must start with a zero, asin 0123, or 0456.

¢ Comments can be in standard C or C++ format.
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Command Explanations

This section explains the commands you can use in a memory configuration file:
e range
* reserved

¢ reservedchar

range

Specifies a memory range for reading or writing.

range <loAddr> <hiAddr> <sizeCode> <access>

Parameters
loAddr
Starting address of memory range.
hiaddr
Ending address of memory range.
sizeCode
Size, in bytes, for memory accesses by the debug monitor or emulator.
access

Read, Write, or ReadWrite.

Example

These range commands specify three adjacent ranges: the first read-only, with 4-
byte access; the second write-only, with 2-byte access; and the third read/write,
with 1-byte access.

range OxFF000000 OxFFOOOOFF 4 Read
range 0xFF000100 OxFFOO0O01FF 2 Write
range 0xFF000200 OxXFFFFFFFF 1 ReadWrite
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reserved

Reserves a range of memory, preventing reads or writes.

reserved <loAddr> <hiAddr>

Parameters
loAddr

Starting address of reserved memory range.
hiaddr

Ending address of reserved memory range.

Remarks

If the debugger tries to write to any address in the reserved range, no write takes
place.

If the debugger tries to read from any address in the reserved range, the system fills
the memory buffer with the reserved character. (Command reservedchar
defines this reserved character.)

Example
This command prevents reads or writes in the range 0xFF00024 — 0xFFO0002F:
reserved OxFF000024 OxFFOO00O02F

reservedchar

Specifies a reserved character for the memory configuration file.

reservedchar <char>

Parameter
char

Any one-byte character.

Remarks

If an inappropriate read occurs, the debugger fills the memory buffer with this
reserved character.
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Example

reservedchar 0xBA
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